Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Conta Numer Excel2007

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Conta Numer Excel2007

Postdi seniorG62 » 14/10/10 13:26

Ciao a tutti i frequentatori di questo splendido Forum ed in particolar modo ai MODERATORI, sempre gentili e molto capaci.
La mia necessità è di CONTARE la quantità di NUMERI per ogni RIGA di una matrice J:O, ma tenendo conto dell'ultimo numero contenuto nella RIGA adiacente Q1:W1.
La FUNZIONE-FORMULA deve, se possibile, contare la quantità di numeri, riga per riga, da J a O, confrontandoli con la RIGA Q1:W1. Se una o più righe della MATRICE contengono il NUMERO della cella "W1", il risultato dovrà essere diminuito di 1a unità ed il risultato numerico dovrà avere a fianco un segno "+".
Ho fatto vari tentativi con funzioni nidificate; ho navigato tantissimo con scarsi risultati.
Spero ci sia la soluzione, confido nelle capacità che normalmente esprime il Forum.

rapidshare.com/files/424999973/ContaNumRighe.xlsm
rapidshare.com/files/425000634/ContaNumRighe.xls
Vi ringrazio in anticipo e spero di aver allegato correttamente.
Cordialmente.
seniorG62 ... in arte ... Giovanni
seniorG62
Utente Junior
 
Post: 72
Iscritto il: 20/07/08 17:37

Sponsor
 

Re: Conta Numer Excel2007

Postdi Anthony47 » 14/10/10 13:48

Prova in AD1 la formula
Codice: Seleziona tutto
=SOMMA(CONTA.SE(J1:O1;Q$1:V$1))&SE(CONTA.SE(J1:O1;W$1)>0;"+";"")
da confermare con Contr-Maiusc-Enter; poi copi verso il basso

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Conta Numer Excel2007

Postdi seniorG62 » 14/10/10 14:24

Ciao Antony,
fantastico come sempre, grazie.
Tutto Ok.
Per favore potresti spiegarmi passo passo cosa devo fare per allegare un file al post, in passato mi riusciva ora no.
Cordialmente, grazie.
seniorG62
seniorG62
Utente Junior
 
Post: 72
Iscritto il: 20/07/08 17:37

Re: Conta Numer Excel2007

Postdi Anthony47 » 14/10/10 21:15

Purtoppo non e' piu' possibile allegare file direttamente "nel sito", va usato un sito di file sharing, come hai fatto; questi siti segnalano la stringa da usare per linkare l' accesso al file direttamente in un forum, tipo http://rapidshare.com/files/425102255/NomeFile.doc: copia tutto (compreso http://) e incollalo nel messaggio, diventera' un link cliccabile.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Conta Numeri2 - Excel2007

Postdi seniorG62 » 15/10/10 18:18

Ciao Antony,
grazie! sempre chiaro, puntuale e professionale.
La formula - matriciale, che mi avevi suggerrito, funziona ed è quella che cercavo. Essa comunque era propedeutica per generare un altro " evento", ovvero evidenziare un valore.
Esempio:la colonna ricevente della formula da te fornita si colloca nella colonna AA1... a discesa... nelle colonne adiacenti da AC ad AI deve apparire il valore da 0 a 6 e successivamente 5+, 4+, 3+, 2+, 1+, 0+, attraverso la formula =SE(AA1=0;"0";""). La presenza della fomula matriciale nella colonna AA1 [url]impedisce il manifestarsi[/url]del valore richiesto dalla formula nelle celle da AC fino ad AI.
Devo presumere che esista la soluzione, che io purtroppo non ho trovato.
Allego, se mi riesce, il file.
http://rapidshare.com/files/425275119/CercaCopiaX.xls
Grazie per la disponibilità.
Cordialmente.
seniorG62
seniorG62
Utente Junior
 
Post: 72
Iscritto il: 20/07/08 17:37

Re: Conta Numer Excel2007

Postdi Anthony47 » 15/10/10 20:00

La formula in col AA restituisce una stringa e NON un numero; quindi tutte le formule che dipendono da AA devono essere riviste: ad esempio in AC1 non =SE(AA1=0;"0";"") ma =SE(AA1="0";"0";"")
Come hai gia' fatto nelle colonne AJ:AO.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Conta Numer Excel2007

Postdi seniorG62 » 15/10/10 21:02

Ciao Antony,
grazie, tutto ok, ho imparato qualcosa ancora.
Cordialmente.
seniorG62
seniorG62
Utente Junior
 
Post: 72
Iscritto il: 20/07/08 17:37


Torna a Applicazioni Office Windows


Topic correlati a "Conta Numer Excel2007":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti