Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] formula contorta

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] formula contorta

Postdi contiend » 26/09/10 23:35

Ciao a tutti,
vorrei sottoporvi la richiesta di una strana formula che spero possa esser trovata .
Vi allego l'immagine uploadata su imageshack sperano che si possa capire meglio :)


Grazie dell'attenzione.

Immagine

ImageShack.us

oppure
http://img442.imageshack.us/img442/6338/immaginehu.jpg
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: [excel] formula contorta

Postdi Anthony47 » 27/09/10 01:00

Nel problema che poni, quali sono gli elementi fissi e quali sono quelli variabili?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] formula contorta

Postdi contiend » 27/09/10 09:43

Mmm.. penso che siano un pò tutti variabili a parte le prime due voci della COLONNA T (ovvero la M e la P).

A volte mi capiterà di avere 5 D, a volte 3 D
oppure
3 D , 5 C e 2 A
(sempre nella colonna T).
I giocatori poi sono sempre variabili.

Dici che non si può fare? Dovrei modificare la struttura per avere una soluzione reale?
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: [excel] formula contorta

Postdi contiend » 27/09/10 10:40

Aggiungo
se può esser d'aiuto, potrei anche inserire il MODULO usato
3-4-3
5-2-3
ecc.. (dovrebbero essercene un pò disponibili)

e dipendentemente dal modulo dovrei ritrovare il posizionamento giusto di giocatori affiancati alla lettera
D, C e A

Grazie ancora dell'aiuto
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: [excel] formula contorta

Postdi Anthony47 » 28/09/10 02:54

Prova cosi':
-in colonna S, su riga 6 (accanto al primo nominativo) inserisci la formula
Codice: Seleziona tutto
=T6&CONTA.SE(T$6:T6;T6)
Copia verso il basso
-Nella formazione di col D, es in D5, inserisci "P1" e sotto, quindi in D6 metti la formula
Codice: Seleziona tutto
=SE(D5="";"";CERCA.VERT(D5;$T$1:$V$100;3;0))

-ripeti in col F inserendo "D1" in F4; nella cella F5 metti la formula copiandola da D6
-continui con questo criterio: in una cella il ruolo (es D2, D3, ...), nella cella sottostante incolli la formula che copi da D6

Con un po' di pazienza potrai farti uno schema aperto a N possibili schieramenti, purche' suddivida il campo in celle bianche=inserire ruolo e celle colorate=con formula

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] formula contorta

Postdi contiend » 28/09/10 09:39

Bè intanto ti ringrazio per la tua disponibilità . Sei veramente un super esperto. Grazie .

La formula funziona benissimo.
Voglio eliminare le SCRITTE D1, D2 ecc dalla formazione ma per quello basta che lo coloro della stessa cromatura del fondo.

Ho un piccolo problema quando nella TABELLA di DESTRA non c'è la 5^ lettera D o la 4^ lettera C ecc..
Il risultato della formula diventa #N/D
E' possibile modificarla in modo che in caso di mancato valore il risultato della forumula non sia #N/D ?

Grazie grazie ancora.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: [excel] formula contorta

Postdi ricky53 » 02/10/10 16:45

Ciao,
puoi farlo con la funzione "VAL.NON.DISP"

prova a sostituire
CERCA.VERT(D5;$T$1:$V$100;3;0)

con
=SE(VAL.NON.DISP(CERCA.VERT(D5;$T$1:$V$100;3;0)); "Non Trovato"; CERCA.VERT(D5;$T$1:$V$100;3;0))

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "[excel] formula contorta":

Formula Rif.riga
Autore: salatony
Forum: Programmazione
Risposte: 0

Chi c’è in linea

Visitano il forum: PcBase e 16 ospiti