Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formule nidificate

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formule nidificate

Postdi seniorG62 » 28/07/10 21:50

Ciao a tutto il Forum.
Ho la seguente tabella:
55 15 77 49 75 6
9 9 9 9 9 9
[url]30 1 15 1 31 1[/url]
94 25 101 59 115 16

I totali di cui sopra sono : (A1:A3)=94; (B1:B3)=25; (C1:C3)=101; (D1:D3)=59; (E1:E3)=35; (F1:F3)= 16.
Quando la somma è tra 91 e 99 devo togliere “90”; = 1 …4 ..… 9.
Quando la somma è di 3 cifre da 101 a 900 devo togliere la terza(III) cifra, ovvero : 10 …11 .... 20 …. 90.

Ho usato questa formula,

=RESTO(SOMMA(A1:A3);90)+SE(SOMMA(A1:A3)>=100;VALORE(STRINGA.ESTRAI(A1:A3;1;2))),
non funziona, dove sbaglio?

Ringrazio a chi vorrà darmi un aiuto.
seniorG62
seniorG62
Utente Junior
 
Post: 72
Iscritto il: 20/07/08 17:37

Sponsor
 

Re: Formule nidificate

Postdi Anthony47 » 28/07/10 23:19

Codice: Seleziona tutto
=SE(E(SOMMA(A1:A3)>90;SOMMA(A1:A3)<100);SOMMA(A1:A3)-90;SE(SOMMA(A1:A3)>100;INT(SOMMA(A1:A3)/10);SOMMA(A1:A3)))

Per "terza cifra" ho interpretato (guardando la tua bozza di formula) "la cifra meno significativa", non so se e' quello che intendevi anche tu.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Formule nidificate

Postdi seniorG62 » 28/07/10 23:39

Ciao Anthony47,
sempre gentilissimo ed efficacissimo; provata e funziona perfettamente.
Un grazie di cuore, era un pò che facevo prove, sono ancora indietro per certe soluzioni. Comunque mi sto impegnando con qualche risultato utile.
Tante belle cose, grazie.
seniorG62
seniorG62
Utente Junior
 
Post: 72
Iscritto il: 20/07/08 17:37


Torna a Applicazioni Office Windows


Topic correlati a "Formule nidificate":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti