Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel, copiare formule saltando righe

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel, copiare formule saltando righe

Postdi Fagoceris » 28/07/10 13:22

Ciao a tutti. Ho un problema che non riesco a risolvere e cerco di spiegarmi.

Ho foglio1 (FIRME ORARIO) e foglio2 (RIEPILOGO MENSILE): devo riuscire in foglio2 a copiare la formula che ho da B6 a C6,D6,ecc. Il problema che la formula è molto lunga e "pesca" i dato da righe non consecutive del foglio1.

Ad esempio in B6 ho:

=SE('FIRME ORARIO'!G411=-0,34;0;SE(O(E('FIRME ORARIO'!G411<6,66;'FIRME ORARIO'!G411>=5,67);'FIRME ORARIO'!G411=4,66;'FIRME ORARIO'!G411=3,66);'FIRME ORARIO'!G411+0,34;SE(('FIRME ORARIO'!G411<=5,66);'FIRME ORARIO'!G411;('FIRME ORARIO'!G411-'FIRME ORARIO'!I411))))

Vorrei poter ricopiare in C6 con un intervallo di 16 celle da foglio1 (FIRME ORARIO) facendo risultare:

=SE('FIRME ORARIO'!G427=-0,34;0;SE(O(E('FIRME ORARIO'!G427<6,66;'FIRME ORARIO'!G411>=5,67);'FIRME ORARIO'!G427=4,66;'FIRME ORARIO'!G427=3,66);'FIRME ORARIO'!G427+0,34;SE(('FIRME ORARIO'!G427<=5,66);'FIRME ORARIO'!G427;('FIRME ORARIO'!G427-'FIRME ORARIO'!I427))))

e così di seguito in D6 dove al posto di G427 dovrebbe risultare G433, ecc.

Spero di essermi spiegato. Il foglio è lungo e non posso pensare di modificare manualmente ogni numero.

Mi aiutate?

Grazie,
Mauro
Fagoceris
Newbie
 
Post: 2
Iscritto il: 28/07/10 13:09

Sponsor
 

Re: Excel, copiare formule saltando righe

Postdi tutamimetica » 28/07/10 14:56

non è elegante, ma dovrebbe funzionare:
in B2 scrivi 411, in C2 427 in D2 433
in B6 =SE(INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)=-0,34;0;SE(O(E(INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)<6,66;INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)>=5,67);INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)=4,66;INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)=3,66);INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)+0,34;SE((INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)<=5,66);INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2);(INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)-INDIRETTO("'FIRME ORARIO'!B"&'RIEPILOGO MENSILE'!B2)))))
copia per trascinamento in C6 e D6
Ciao tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: Excel, copiare formule saltando righe

Postdi Anthony47 » 28/07/10 23:13

Ciao Fagoceris e benvenuto nel forum.
In alternativa all' efficace metodo suggerito da tutamimetica, puoi sostituire nella formula di B2 le parti 'FIRME ORARIO'!G411 con Scarto('FIRME ORARIO'!G411;16*(rif.riga(A1)-1);0)
Poi potrai copiare la formula nelle celle sottostanti.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel, copiare formule saltando righe

Postdi Fagoceris » 28/07/10 23:15

Grandioso!!! Ho sostituito le B della tua formula con la G che mi serviva nel riferimento e il gioco è fatto! Funziona!!!!!


Grazie 10 milioni di volte! Erano 2 mesi che mi spremevo su questo foglio!!
Fagoceris
Newbie
 
Post: 2
Iscritto il: 28/07/10 13:09


Torna a Applicazioni Office Windows


Topic correlati a "Excel, copiare formule saltando righe":


Chi c’è in linea

Visitano il forum: patel e 16 ospiti