Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

DA =ADESSO() A TESTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

DA =ADESSO() A TESTO

Postdi pippo1300 » 14/07/10 08:19

VORREI SAPERE SE SI PUO' CON UNA FORMULA (ho con qualche altro modo)
TRASFORMARE UNA CELLA CON =ADESSO() [quindi formato data aaaa corrispondente 2010]
in testo 2010 [formato testo 2010] in un' altra cella.

Esempio A1 [=ADESSO()] > > > D1[2010] al modificarsi degli anni si modificherebbe come testo

GRAZIE ANTICIPATAMENTE A CHI MI POTREBBE AIUTARE.
pippo1300
Utente Junior
 
Post: 20
Iscritto il: 23/06/10 11:22

Sponsor
 

Re: DA =ADESSO() A TESTO

Postdi maxmula » 14/07/10 09:04

Se metti la formula nel foglio di calcolo puoi assegnare alla cella il formato voluto.
Menu Formato/celle; scegli il formato data che preferisci, oppure vai su Personalizzato e definisci tu quello che vuoi.

In alternativa puoi fare così:
- Apri VB Editor (ALT-F11) ed aggiungi un modulo.

- Nel modulo, inserisci questo codice:

Codice: Seleziona tutto
Function MIADATA(DATA)
    MIADATA = Format(DATA, "dd/mm/yyyy, HH:MM:ss")
End Function


e nella cella metti la formula:
Codice: Seleziona tutto
=MIADATA(ADESSO())




Se poi richiami la guida di VBA, puoi trovare un sacco di informazioni sulla funzione Format, così da crearti i lformato che ti serve.

Ciao!
MAx
Avatar utente
maxmula
Utente Senior
 
Post: 965
Iscritto il: 18/08/04 18:28
Località: N44°59'45 E09°00'34

Re: DA =ADESSO() A TESTO

Postdi Flash30005 » 14/07/10 09:20

pippo1300 ha scritto:VORREI SAPERE SE SI PUO' CON UNA FORMULA (ho con qualche altro modo)
TRASFORMARE UNA CELLA CON =ADESSO() [quindi formato data aaaa corrispondente 2010]

:roll: :?:

Ciò che chiedi è contraddittorio perché se è una formula non è testo
a meno che tu non voglia avere apparentemente e visivamente il formato testo dell'anno che è in A1
allora puoi utilizzare questa formula
="'" & ANNO(A1)

o questa
Codice: Seleziona tutto
=TESTO(ANNO(A1);0)

ma ripeto è una formula non testo per avere in formato testo devi usare una macro con solo una riga di codice, tipo:
Codice: Seleziona tutto
Sub TrasfTesto()
[D1] = "'" & Year(Range("A1").Value)
End Sub


Che avvierai ad ogni apertura del file o attivazione foglio o con qualsasi altro input

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: DA =ADESSO() A TESTO

Postdi pippo1300 » 14/07/10 11:21

=TESTO(ANNO(A1);0)

MI VA BENISSIMO GRAZIE 1000
pippo1300
Utente Junior
 
Post: 20
Iscritto il: 23/06/10 11:22


Torna a Applicazioni Office Windows


Topic correlati a "DA =ADESSO() A TESTO":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti