Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerca vert e indiretto help

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca vert e indiretto help

Postdi fabmon » 22/04/10 09:30

Salve a tutti, ho un problema con la funzione cerca vert. Ho cercato nei topic ma mi pare che non facciano al caso mio.
Il mio problema è questo:
ho 2 fogli di lavoro nel primo c'è l'elenco di tutti i passeggeri di una nave nel secondo c'è soltanto l'elenco di quei passeggeri che hanno al seguito un'auto con la relativa targa.
Problema: vorrei aggiungere nel primo elenco soltanto le targhe del secondo elenco
ho provato ad utilizzare la formula =cerca.vert(indiretto(a1);autisti!a1:f100;2;falso) rif
=CERCA.VERT(C8;autisti!A1:F100;2;FALSO) valore non disp
ovvero cerca il nome del primo passeggero nel foglio autisti se presente inserisci la targa della colonna 2
ma mi dà errore. Non riesco a venirne a capo
fabmon
Newbie
 
Post: 1
Iscritto il: 22/04/10 08:52

Sponsor
 

Re: cerca vert e indiretto help

Postdi gudmund » 22/04/10 14:13

io proverei con se() + val.non.disp() + cerca.vert()
=se(val.non.disp(CERCA.VERT(C8;autisti!$A$1:$F$100;2;FALSO))=vero;"";CERCA.VERT(C8;autisti!$A$1:$F$100;2;FALSO))
ma penso che i mod troveranno qualcosa di più leggibile :oops:
gudmund
Utente Junior
 
Post: 50
Iscritto il: 21/06/07 14:09

Re: cerca vert e indiretto help

Postdi ricky53 » 22/04/10 16:44

Ciao,
quanto consigliato da gudmund mi sembra valido.
Con l'ipotesi che
1. in "C8" c'è l'identificatvio "UNIVIOCO" del passeggero
2. in "autisti" "A" ci sono i corrispondenti identificativi dei passeggeri
3. in "autisti" "B" ci sono le targe degli automezzi al seguito

Io avrei scritto:

=SE(VAL.NON.DISP(CERCA.VERT(C8; autisti!$A$1:$B$100; 2; FALSO)); "Senza auto al seguito"; CERCA.VERT(C8; autisti!$A$1:$B$100; 2; FALSO))

Ma solo per motivi legati alla mia deformazione professionale.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: cerca vert e indiretto help

Postdi Flash30005 » 23/04/10 09:27

Ciao Fabmon e benvenuto nel Forum

Se vuoi risolvere con unsa semplice macro puoi inserire questo codice nel modulo

Codice: Seleziona tutto
Sub TrovaTarga()
URP = Sheets("Foglio1").Range("A" & Rows.Count).End(xlUp).Row
URT = Sheets("Foglio2").Range("A" & Rows.Count).End(xlUp).Row
For RT = 2 To URT
    PTa = UCase(Sheets("Foglio2").Range("A" & RT).Text)
    For RP = 2 To URP
        PPa = UCase(Sheets("Foglio1").Range("A" & RP).Text)
        If PTa = PPa Then Sheets("Foglio1").Range("B" & RP).Value = Sheets("Foglio2").Range("B" & RT).Value
    Next RP
Next RT
End Sub

Ho considerato il primo rigo testata
la colonna "A" nome passeggero (sia per il foglio1 che foglio2)
nella colonna B del foglio2 la targa auto
dopo l'esecuzione della macro avrai la targa nel foglio ad ogni corrispondenza del nome che si trova nel foglio 2

Allego anche il questo file come esempio

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: cerca vert e indiretto help

Postdi raimea » 24/04/10 04:46

ottimo
io ho provato il file e funziona
http://www.lelugarine.eu
S.O. Seven7, Excell 2010
Avatar utente
raimea
Utente Senior
 
Post: 1101
Iscritto il: 11/02/10 07:33
Località: lago

Re: cerca vert e indiretto help

Postdi ricky53 » 24/04/10 11:08

Ciao,
hai provato la formula suggertia da gudmund con la mia piccola precisazione?

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "cerca vert e indiretto help":


Chi c’è in linea

Visitano il forum: Nessuno e 27 ospiti