Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Calcolo orario

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Calcolo orario

Postdi volpe » 08/02/10 20:22

Salve,
è da un po’ che sto cercando di risolvere questo problema.
In excel, ho differenti intervalli orari che potrebbero essere continui o discontinui, tipo:

Ora entrata Ora uscita
08.30 09.15
09.16 10.20
10.30 15.07
15.08 16.04


Dovrei riuscire a estrapolare/calcolare quale orario di entrata è maggiore di almeno due minuti dall’orario di uscita (in questo caso h.10.30).

Ma se ci sono più orari di entrata maggiori di almeno due minuti dall’orario di uscita mi dovrebbe dare quello più a tarda ora (es.18.05).

Ora entrata Ora uscita
08.30 09.15
09.16 10.20
10.30 15.07
15.08 16.04
18.05 20.04

All’orario estrapolato poi devo aggiungere i minuti che sono presenti in un’altra cella.

Spero di essere stato chiaro.
Come si può risolvere senza utilizzare una macro???

Grazie a tutti per l’aiuto.
volpe
Newbie
 
Post: 8
Iscritto il: 08/02/10 19:57

Sponsor
 

Re: Calcolo orario

Postdi Anthony47 » 09/02/10 19:12

Ciao volpe e benvenuto nel forum.
Non dici molto sulla tu struttura dati; nel caso che Entrata sia in A1:A10 e Uscita B1:B10, allora usa una formula come questa:
Codice: Seleziona tutto
=INDICE(A1:A10;MAX(SE(A2:A10>=(B1:B9+ORARIO(0;2;0));RIF.RIGA(A2:A10);"")))
da confermare con Contr-Maiusc-Enter
Ti dara' l' ultimo valore che risulta superiore di almeno due minuti rispetto all' uscita precedente; per sommargli i minuti che sono in altra cella userai il segno +, facendo attenzione che la natura dei dati sommati sia la stessa (cioe' che i minuti di cui parli siano rspressi anche loro come "valore orario", altrimenti convertirai usando la funzione Orario.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Calcolo orario Excel

Postdi volpe » 10/02/10 23:02

Anthony grazie per la risposta.
è vero non sono stato molto preciso.
Ho provato la formula da te proposta ma non va bene per il mio scopo.
La mia struttura dati è:


A B
1 Ora Entrata Ora Uscita
2 8.30 am 9.15 am
3 9.16 am 10.20 am
4 10.30 am 3.07 pm
5 3.08 pm 5.15 pm

e nella cella C7 ho il i minuti che devo aggiungere.

La formula dovrebbe restituirmi, tra i valori presenti, l’ultima ora d’entrata che è superiore di almeno due minuti dall’ora di uscita precedente. Nell’esempio dovrebbe restituirmi l’ora d’entrata 10.30 presente in (A4), naturalmente se gli orari fossero differenti tipo:


A B
1 Ora Entrata Ora Uscita
2 8.30 am 9.15 am
3 9.16 am 10.20 am
4 10.30 am 3.07 pm
5 4.08 pm 5.15 pm

allora dovrebbe restituirmi l’ora d’entrata 4.08 presente.

Questa volta spero di essere stato più preciso.

Grazie ancora.
Ciao.
volpe
Newbie
 
Post: 8
Iscritto il: 08/02/10 19:57

Re: Calcolo orario Excel

Postdi volpe » 10/02/10 23:06

Scusate se l'impostazione della mia struttura dati non è stata pubblicata con la tabella come avrei voluto.
Devo ancora imparare ad usare bene il forum.
I riferimenti sono:
Ora entrata: A2:A5
Ora Uscita: B2:B5


Ciao
volpe
Newbie
 
Post: 8
Iscritto il: 08/02/10 19:57

Re: Calcolo orario

Postdi Anthony47 » 11/02/10 02:38

La formula data valeva per l' area A1:A10; se e' A2:A10 la adatterai in quest'altra:
Codice: Seleziona tutto
=INDICE(A1:A10;MAX(SE(A3:A10>=(B2:B9+ORARIO(0;2;0));RIF.RIGA(A3:A10);"")))
Sempre Cotr-Maiusc-Enter
Al valore ottenuto aggiungerai C7, direttamente se C7 e' gia' in notazione "oraria", oppure tramite Orario(0;C7;0) se invece C7 e' un numero puro.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Calcolo orario":


Chi c’è in linea

Visitano il forum: patel e 13 ospiti