Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cercare dati

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cercare dati

Postdi amenothep » 09/09/09 13:37

Buongiorno a tutti, scrivo subito perchè ho un problema da risolvere. premetto che non sono un conoscitore di excel ma sono sicuro che questo programma è in grado di risolvere il mio problema. in un foglio excel utilizzo 12 caselle orizzontali, dalla A alla L. nelle celle A-C-E-G-I-K devo digitare un numero che va da 1 a 6, ed a seconda del numero digitato,nella cella subito a destra deve comparire un altro numero.
faccio un esempio:
se dico che 1 vale 15, 2 vale 20, 3 vale 25, 4 vale 30, 5 vale 35 e 6 vale 40, quando vado nella cella A ed inserisco 3, nella cella B mi compare 25. se nella cella G digito 5 nella cella H mi compare 35.
i valori delle cifre 1-2-3-4-5-6 potranno variare secondo la mia necessità.
spero di essere stato abbastanza chiaro e di aver fatto un esempio comprensibile.
ringrazio già sin da ora tutti coloro che vorranno aiutarmi a trovare la soluzione ottimale.
P.S. EVENTUALMENTE FATEMI UN ESEMPIO
un cordiale saluto a tutti
amenothep
amenothep
Utente Junior
 
Post: 12
Iscritto il: 31/07/09 03:17

Sponsor
 

Re: cercare dati

Postdi neverlandce » 09/09/09 17:01

Ciao,
non sono un esperto premesso, secondo me dovresti usare la funzione "SE" abbinata alla funzione "CERCA.VERT"
Tipo questa =SE(A1=1;CERCA.VERT($Y$2;$W$1:$X$41;2;)). Questa che ho scritto prevede la ricerca su 40 numeri, inseriti nella colonna X. Nella colonna W scrivi i nr da 1 a 40 o da 1 a 6, nella colonna X i valori corrispondenti 28-30-35 ect, nella colona Y il valore di ricerca 1 in corrsipondenza del 25 (colX) 2 in corrispondenza del 30(colx) ect..
Prov così,ma tra poco riceverai dalle persone eperte maggiore indicazioni.
ciao
neverlandce
Utente Junior
 
Post: 48
Iscritto il: 27/08/09 18:09

Re: cercare dati

Postdi Anthony47 » 10/09/09 15:14

Da come l' hai descritta dovrebbe bastare questa formula in Bx
Codice: Seleziona tutto
=Ax*5+10
X e' il numero di riga su cui lavori; poi copi Bx in Cx, Ex etc

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cercare dati

Postdi amenothep » 10/09/09 16:00

Scusate ragazzi, vi ringrazio per le risposte ma forse avete dimenticato che non conosco excel e quindi ho bisogno di un esempio chiaro e ho bisogno di sapere cosa devo fare passo per passo.
Vi ringrazio anticipatamente
Amenothep
amenothep
Utente Junior
 
Post: 12
Iscritto il: 31/07/09 03:17

Re: cercare dati

Postdi neverlandce » 11/09/09 11:51

Amenothep scarica questo file cosi vedi come funziona

http://rapidshare.com/files/278525977/C ... E.xls.html

ciao
neverlandce
Utente Junior
 
Post: 48
Iscritto il: 27/08/09 18:09

Re: cercare dati

Postdi Flash30005 » 12/09/09 16:39

Se i valori sono quelli che hai inserito la semplice formula che ha postato Anthony calza a pennello.
Per usarla ti posizioni in B2 (non so dove iniziano i dati, ammettiamo A2) e incolli questa formula
Codice: Seleziona tutto
=A2*5+10
e la trascini in verticale fino dove occorre (es.B100) poi copi il range da B2:B100 (o l'intera colonna se non hai la testata) e la incolli in D2, ti posizioni F2 e incolli fino a L2 incolli l'ultima
Con qualsiasi numero inserito in A o C o E o G etc fino alla riga 100 avrai la corrispondenza (da formula) nelle colonne adiacenti B, D, F etc
Se, invece, i valori di corrispondenza non hanno quell'algoritmo ma possono variare allora devi crearti una tabella di riferimento (Es: In Q1:R7) qualcosa del genere
Codice: Seleziona tutto
Riferimenti   
1   15
2   20
3   25
4   30
5   35
6   40

15, 20, 25 etc possono variare

poi in B2 incolli questa formula
Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT(A2;$Q$2:$R$7;2;FALSO))=VERO;"";CERCA.VERT(A2;$Q$2:$R$7;2;FALSO))

trascini in verticale e poi copi la colonne in tutte le altre (come passaggio precedente)

Comunque invio il file
http://rapidshare.com/files/279100935/CercaVerticale.zip.html

Fai sapere
Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "cercare dati":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti