Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] - Salta celle con saldo zero

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] - Salta celle con saldo zero

Postdi il_perozzi » 02/09/09 20:42

Ciao a tutti, ho un problema su un file excel che spero possiate risolvere per me.
ho una tabella dove sono ripetute tante righe per quante sono le fatture secondo uno schema classico
a= codice
b=nome
c=numero
...
g= importo... e cosi via

ora il problema è che quando incasso le fatture ho 2 righe dove (colonna "C" numero uguale) ed in colonna "G" ho il medesimo numero una volta con segno positivo ed un'altra volta il numero negativo,io vorrei estrarre solo quelle che, a parità di numero fattura il saldo sia diverso da zero, nell'esempio sotto riportato mi estragga solo le righe 6-7-8-9-10 e 11, come posso fare?

spero di essere stato chiaro, posso eventualmente allegare il file.
grazie come sempre per l'aiuto,

ESEMPIO
RIGA A B C D E F G H
1 COD RagSoc1 NR DATA SCADENZA Operazione IMPORTO PagDes
2 36 MARIO ROSSI 1651 31/03/2009 30/09/2009 FATTURA 217,56 CONTANTI
3 36 MARIO ROSSI 1651 31/03/2009 30/09/2009 PAGAMENTO -217,56 CONTANTI
4 36 MARIO ROSSI 2355 30/04/2009 30/09/2009 FATTURA 888,44 CONTANTI
5 36 MARIO ROSSI 2355 30/04/2009 30/09/2009 PAGAMENTO -888,44 CONTANTI
6 36 MARIO ROSSI 1274 08/05/2009 30/04/2009 FATTURA 4.856,11 CONTANTI
7 36 MARIO ROSSI 2650 08/05/2009 08/05/2009 FATTURA 2,00 CONTANTI
8 36 MARIO ROSSI 1648 09/06/2009 31/05/2009 FATTURA 4.856,11 CONTANTI
9 36 MARIO ROSSI 3589 09/06/2009 09/06/2009 FATTURA 2,00 CONTANTI
10 36 MARIO ROSSI 1906 08/07/2009 30/06/2009 FATTURA 4.856,10 CONTANTI
11 55 LUIGI BIANCHI 5050 10/08/2009 30/09/2009 FATTURA 1.000,00 CONTANTI

il_perozzi
il_perozzi
__________________________________________
(blinda la supercazzora .....con lo scappellamento a destra come fosse antani)

Win 10 - Excel 2010
Avatar utente
il_perozzi
Utente Junior
 
Post: 87
Iscritto il: 23/05/07 12:28
Località: roma

Sponsor
 

Re: [Excel] - Salta celle con saldo zero

Postdi pietrol » 02/09/09 22:13

Ciao il_perozzi
prova così:
aggiungi in I1 un titolo(qualcosa come "Saldo partita", vedi tu)
poi in I2 copia la formula
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--($A$2:$A$1000=A2);--($C$2:$C$1000=C2);$G$2:$G$1000)

ovviamente se sono più di 100 righe adatta al range.
Trascina sulle celle sottostanti e poi filtra per "diverso da 0"

Fai sapere

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: [Excel] - Salta celle con saldo zero

Postdi il_perozzi » 03/09/09 09:21

Perfetto !!! :)
problema risolto (come sempre).

Un saluto e a presto.

il_perozzi
il_perozzi
__________________________________________
(blinda la supercazzora .....con lo scappellamento a destra come fosse antani)

Win 10 - Excel 2010
Avatar utente
il_perozzi
Utente Junior
 
Post: 87
Iscritto il: 23/05/07 12:28
Località: roma


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] - Salta celle con saldo zero":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti