Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Problema con il COUNTIF

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Problema con il COUNTIF

Postdi al3ssio » 26/08/09 10:13

Ciao a tutti,

Ho appena scoperto, ma spero di sbagliarmi, un bug di excel nella funzione COUNTIF. Mi trovo spesso a dover confrontare stringhe e a contare quante sono. Ma, a volte, il calcolo fatto da excel è errato!

Ad esempio, ho queste le due stringhe seguenti di numeri memorizzati come testo (ho fatto ""&numero per avere il numero sotto questa forma):
500013003330107825
500013003330107909

Ebbene, se voi le prendete e le mettete su excel, la formula countif le vede come uguali!!!

Sapete spiegarmi la causa di questo "apparente" bug? Per caso si ferma alla 15ma cifra per fare confronto?

Grazie mille!

Alessio
al3ssio
Utente Senior
 
Post: 234
Iscritto il: 08/05/04 15:59

Sponsor
 

Re: Problema con il COUNTIF

Postdi Anthony47 » 26/08/09 11:09

Quale formula usi, e che risulati ottieni?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Problema con il COUNTIF

Postdi al3ssio » 26/08/09 11:14

Se il primo numero è nella cella A1 e il secondo nella cella A2:
=countif(A1:A2,A1) e =countif(A1:A2,A2) ed il risultato è 2 per entrambi, quindi sono visti come uguali!
al3ssio
Utente Senior
 
Post: 234
Iscritto il: 08/05/04 15:59

Re: Problema con il COUNTIF

Postdi Anthony47 » 26/08/09 14:58

Si, come hai intuito e' legato alla precisione max a 15 cifre dei calcoli che excel fa; nel caso specifico, come tra l' altro spesso excel fa, le stringhe vengono elaborate come numero.
Per aggirare l' ostacolo, o modifiche le stringhe perche' non somiglino piu' a un numero (es fai "N"&numero), oppure usi Matr.Somma.Prodotto; es
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A1:A100=B2))


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Problema con il COUNTIF":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti