Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

MATRICE.SOMMA.PRODOTTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

MATRICE.SOMMA.PRODOTTO

Postdi dipic » 20/05/09 13:38

Ho un problema, credo di impostazione della formula.
Ho la seguente formula che funziona perfettamente:
=MATR.SOMMA.PRODOTTO(--(B1:B27="SUB TOTAL");(I1:I27))

Ma se sostituisco i parametri dei range con formule che restituiscono gli stessi range
=CONCATENA(INDIRIZZO(1;2);":";INDIRIZZO(RIF.RIGA(I28)-1;2))
=CONCATENA(INDIRIZZO(1;9);":";INDIRIZZO(RIF.RIGA(I28)-1;9))

mi restituisce "#VALORE" .... anche se racchiudo le 2 formule in INDIRETTO() ...
Qualcuno può indicarmi dove stò sbagliando?
Grazie per qualsiasi aiuto
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Sponsor
 

Re: MATRICE.SOMMA.PRODOTTO

Postdi dipic » 20/05/09 13:46

La stessa con SOMMA() funziona perfettamente
=SOMMA(INDIRETTO(CONCATENA(INDIRIZZO(1;9);":";INDIRIZZO(RIF.RIGA(I28)-1;9))))


?????
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Re: MATRICE.SOMMA.PRODOTTO

Postdi Anthony47 » 21/05/09 02:37

Puoi dare un paio di formule, ad esempio, che non ti funzionano?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: MATRICE.SOMMA.PRODOTTO

Postdi dipic » 21/05/09 09:49

=MATR.SOMMA.PRODOTTO(--((INDIRETTO(CONCATENA(INDIRIZZO(1;2);":";INDIRIZZO(RIF.RIGA(I28)-1;2))))="SUB TOTAL");INDIRETTO(CONCATENA(INDIRIZZO(1;9);":";INDIRIZZO(RIF.RIGA(I28)-1;9))))


questo è l'esempio per intero, praticamente ho 2 colonne, cerco sulla B "SUB TOTAL" e sommo il contenuto della colonna I.
la cella di riferimento I28 è quella contenente il totale.
Grazie per l'interessamento
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Re: MATRICE.SOMMA.PRODOTTO

Postdi Anthony47 » 21/05/09 15:31

Inserendo la formula che calcola la stringa indirizzo all' interno della formula matrice, ti ritrovi con piu' funzioni annidate; l' espressione "matrice" viene associata alla piu' interna, cioe' a Rif.riga, falsando con cio' il rsultato atteso da sottoporre a Indiretto.
La formula postata e' semplificabile in
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--((INDIRETTO(CONCATENA(INDIRIZZO(1;2);":";INDIRIZZO(27;2))))="SUB TOTAL");INDIRETTO(CONCATENA(INDIRIZZO(1;9);":";INDIRIZZO(27;9))))
che viene elaborata correttamente; se hai bisogno di mantenere il calcolo basato su Rif.riga allora il suggerimento e' di calcolare le stringhe indirizzo in due celle di appoggio e usare poi Indiretto(Cella-di-appoggio-1) all' interno della formula finale.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: MATRICE.SOMMA.PRODOTTO

Postdi dipic » 21/05/09 16:00

a volte la soluzione più semplice è sempre la migliore ... non ci avevo nemmeno pensato ...
userò una cella d'appoggio
grazie 1000
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)


Torna a Applicazioni Office Windows


Topic correlati a "MATRICE.SOMMA.PRODOTTO":


Chi c’è in linea

Visitano il forum: albval e 84 ospiti