Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

formare coppie con ricerca random

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

formare coppie con ricerca random

Postdi alessandro75 » 25/03/09 21:45

Innanzitutto saluto e ringrazio anticipatamente chi volesse aiutarmi in questo mio problema...

-Ho un elenco di nomi accoppiati tra loro(all\'incirca 60 coppie)-

-Avrei la necessità che, queste coppie da me immesse,si riformassero, rimescolandosi fra loro senza mai ripetersi.
:undecided:
alessandro75
Newbie
 
Post: 6
Iscritto il: 25/03/09 21:35

Sponsor
 

Re: formare coppie con ricerca random

Postdi Anthony47 » 26/03/09 15:18

Ciao alessandro e benvenuto nel forum.
Con le informazioni fornite la mia risposta e' un generico "penso si possa fare".
Per una prognosi piu' dettagliata dovresti specificare come sono organizzati i tuoi nomi, come vuoi l' output e che cosa intendi con "senza mai ripetersi".
Tra l' altro: vuoi generare delle coppie randomiche o tutte e sole le possibili permutazioni dei 60 elementi?

Ciao, ti aspettiamo.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formare coppie con ricerca random

Postdi alessandro75 » 26/03/09 18:30

Grazie di avermi preso in considerazione.... :)
-Immaginavo di dovermi spiegare meglio, la mia era una provocazione ad una risposta interessata, perciò Grazie di
nuovo:
la questione è la seguente- ( immissione nomi delle coppie colonna A-B .-n matematici a due decimali relativi ad1°nome colonna C.- n° matematici a due decimali relativi a 2°nome colonna D

Es:-
colonna A colonna B colonna C Colonna D
Angela Rossi Alberta Bianchi 127.27 128.28
Franco Verdi Isa Fortunati 217.11 281.81

-Di seguito per 60 coppie con relativi numeri:
a questo punto averei la necessità di fare in modo che _ Angela Rossi _ (e tutti gli altri) non si trovi più in coppia con _Alberta Bianchi_ ma con un'altra qualsasi, trasportando con se anche il suo relativo numero; lo stesso vale per il secondo nome a lei assegnato.
Così di seguito ogni volta che si desidera scambiare....
Spero tanto di essere stato abbastanza chiaro
Grazie per il benvenuto e spero tanto di poter dare anche io un giorno un qualche contributo.....
alessandro75
Newbie
 
Post: 6
Iscritto il: 25/03/09 21:35

Re: formare coppie con ricerca random

Postdi Anthony47 » 27/03/09 00:46

Puoi fare cosi':
Su Foglio4 ti crei l' elenco dei nominativi, da riga 2 in giu':
-col C, Nominativo
-col D, Punteggio
-in B2, formula
Codice: Seleziona tutto
=CASUALE()

-in A2, formula
Codice: Seleziona tutto
=RANGO(B2;B:B)

-copia A2:B2 verso il basso per tutti i nominativi disponibili

Su foglio 1, in A2, B2, C2 e D2 metti rispettivamente queste formule
Codice: Seleziona tutto
=CERCA.VERT((RIF.RIGA()-2)*2+1;Foglio4!A:D;3;0)
=CERCA.VERT((RIF.RIGA()-2)*2+2;Foglio4!A:D;3;0)
=CERCA.VERT((RIF.RIGA()-2)*2+1;Foglio4!A:D;4;0)
=CERCA.VERT((RIF.RIGA()-2)*2+2;Foglio4!A:D;4;0)
Copi poi A2:D2 verso il basso per quante coppie devi formare.

Imposta quindi il ricalcolo su Manuale: Menu /Strumenti /Opzioni, tab Calcolo, imposra Manuale.
Ogni volta che premi F9 il foglio calcolera' nuovi accoppiamenti.

Puo' essere idoneo?
Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formare coppie con ricerca random

Postdi alessandro75 » 27/03/09 18:43

carissimo !!!
ritieniti abbracciato.. stretta di mano e bacio accademico !!! :P

ho provato e funziona benissimo...
ma ... con tutto il rispetto, umilmente chiedo:
si potrebbe fare a meno del ricalcolo manuale dato che sarebbe un'aplicazione ad un foglio esistente, e siamo certi che nessuna delle coppie si ricompongano ?
Scusa l'ardire e se dico stoltezze :)
alessandro75
Newbie
 
Post: 6
Iscritto il: 25/03/09 21:35

Re: formare coppie con ricerca random

Postdi Anthony47 » 29/03/09 16:53

e siamo certi che nessuna delle coppie si ricompongano ?
NO, anzi possiamo essere certissimi che max dopo 119 combinazioni una coppia si ricombinera'. D' altra parte non avevi risposto alla domanda "vuoi generare delle coppie randomiche o tutte e sole le possibili permutazioni dei 60 elementi?" (nb: avrei dovuto scrivere "120 elementi") e mi sono limitato a darti coppie randomiche.
Prima di darti una soluzione alla prima osservazione (evitare l' uso del ricalcolo manuale), basata su macro attivata con un pulsante avrei quindi bisogno di un chiarimento su che cosa intendi per "coppia con ricerca random".

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formare coppie con ricerca random

Postdi alessandro75 » 29/03/09 18:09

Ok. Scusami, devo fare un me-culpa...
Credevo fosse chiaro ed evidentemente sbagliavo-
Provo ora ad esserlo :
_ Ho in un foglio di nomi accopiati fra loro, con inserite nella stessa riga, ma in celle diverse, i relativi numeri corrispondenti ad ogni singolo individuo della coppia.
_ Le coppie sono all'incirca 60 (ovvero 120 nomi e reltivi numeri)
_ La necessità è ; una volta inserite le coppie nel foglio esistente, estrapolare le stesse con i relativi numeri, ricomporle per un numero più alto possibile di volte senza che mai si ripeta la la coppia.
Come detto ora la cosa funziona....
Giustamente, mi rispondi che se i nomi sono 120 è inevitabile che non essendo un numero infinito prima o poi si ritrovano, allora mi chiedo se è possibile mettere un contatore e a quel punto bloccare il tutto, per poi sbloccare una volta inseriti nuovi dati (nomi).
Spero di essere stato un po più chiaro.
Se ti serve sapere come funziona in foglio esistente, penso farei meglio a spedirtelo, mi rimane complicato a spiegartelo in italiano :-?
Ciao e grazie comunque per avermi aiutato.
alessandro75
Newbie
 
Post: 6
Iscritto il: 25/03/09 21:35


Torna a Applicazioni Office Windows


Topic correlati a "formare coppie con ricerca random":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti