Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel Problema formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel Problema formula

Postdi Statix » 30/11/08 21:10

Ciao Anthony,
ho un problema con questa formula ,funziona perfettamente,unico problema che mi da i risultati dell'archivio in esame ,all'incontrario,cioè parte dall'alto,a me servirebbe quelli da basso dell'archivio.
Codice: Seleziona tutto
=SE(VAL.ERRORE($A$3-INDICE($A$3:$A$5000;CONFRONTA($P3;$I$3:$I$5000;0)));"";$A$3-INDICE($A$3:$A$5000;CONFRONTA($P3;$I$3:$I$5000;0)))

per avere i risultati esatti devo girare l'archivio con un filtro.
archivio
Range I3:M5000
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Excel Problema formula

Postdi Anthony47 » 30/11/08 21:18

Ohi ohi, non farmi fare il reverse engineering della formula... dimmi che cosa vuoi calcolare e faccio meno fatica; e ti assicuro che prendero' lo spunto dalla tua formula!

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel Problema formula

Postdi Statix » 30/11/08 21:29

Ciao Anthony, la formula mi calcola il ritardo di posizione per ogni colonna dell'archivio
allego 2 foto , nella prima foto la formula calcola un archivio di 4034 estrazioni partendo dall'alto Range I3:M3.
il numero 1 Q3 da come risultato 23,
a me serve calcolare il ritardo partendo dal basso vedi foto 2
il numero 1 dovrebbe darmi in Q3 = 9

Immagine

Immagine
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel Problema formula

Postdi Anthony47 » 01/12/08 00:32

Prefrisco non ispirarmi alla tua formula, so che mi perdonerai :D
Prova a mettere in Q3 la formula
Codice: Seleziona tutto
=4036-MAX(RIF.RIGA($3:$4036)*(I$3:I$4036=$P3))
che CONFERMERAI NON CON enter MA con Contr-Maiusc-Enter.
Poi copi Q3 sulle colonne R3:U3, e Q3:U3 in Q4:Q4036

Fai sapere, ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel Problema formula

Postdi Statix » 01/12/08 01:14

Ciao Anthony,
tutto ok,ho solo dovuto riadattare la formula ai miei archivi,in quanto le estrazioni sono variabili da archivio ad archivio,la ruota Nazionale ha meno archivi, in più ad ogni estrazione ne viene aggiunta 1.
Grazie.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel Problema formula

Postdi RPD » 22/12/08 23:53

Salve,
sto lavorando su un archivio molto simile a quello su riportato da Statix per cui intervengo in questa discussione per chiedere a chi più esperto di me come posso modificare la formula di Anthony47 in modo che calcoli il ritardo di un numero partendo sì dal basso ma non necessariamente dall'ultima estrazione dell'archivio bensì da una da me specificata in un'altra casella. Ovvero: facendo un esempio sulle immagini riportate da Statix, quale formula dovrebbe esserci in Q3 perché mi dia il ritardo del numero 1 partendo non dall'estrazione 4034 bensì da un'altra da me specificata in C3 (facciamo conto che in C3 io specifichi 4030, il ritardo che dovrebbe risultare sarebbe 5).
Spero di essere stato abbastanza chiaro!
Grazie a tutti
RPD
Utente Junior
 
Post: 35
Iscritto il: 21/12/08 16:53

Re: Excel Problema formula

Postdi Anthony47 » 24/12/08 02:16

Ciao RPD e benvenuto nel forum.
Per quello che chiedi dovrai usare la funzione Indiretto:
-dato il tuo punto di partenza in C3, metti in D3 (o altra cella libera) la formula
Codice: Seleziona tutto
=C3+2
(dove 2 e' il numero di righe vuote prima della prima estrazione)
-poi in Q3 userai
Codice: Seleziona tutto
=$D$3-MAX(RIF.RIGA(INDIRETTO("$3:$"&$D$3))*((INDIRETTO("I3:I"&$D$3))=$P3))
Sempre da confermare con Contr-Maiusc-Enter
Puoi copiare la formula in verticale senza problemi, mentre copiandola in orizzontale dovrai modificare in la stringa "I3:I" in "J3:J", "K3:K", etc.

Ciao, fai sapere.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel Problema formula

Postdi RPD » 27/12/08 14:13

Grazie Anthony,
la formula modificata sembra fare proprio al caso mio. Solo una cosa: la formula restituisce la prima presenza di un numero salendo dal basso verso l'alto (diciamo così tanto per intenderci); nel caso la formula non ritrovi nessuna presenza restituisce il max ritardo (se l'insieme è da 1 a 4000 restituisce 4000) quando invece preferirei che in quel caso la cella rimanesse vuota. Solitamente la cella vuota io la ottengo con la funzione SE, ma dato che non ho alcuna dimestichezza con le formule in forma di matrice (sono molto efficaci ma ho iniziato a impiegarle da poco, ispirato dai tuoi suggerimenti nei post) gradirei un tuo aiuto!
Grazie
RPD
Utente Junior
 
Post: 35
Iscritto il: 21/12/08 16:53

Re: Excel Problema formula

Postdi Anthony47 » 29/12/08 15:59

Coma hai intuito e' necessario mettere la formula data in un SE:
Codice: Seleziona tutto
=SE(MAX(RIF.RIGA(INDIRETTO("$3:$"&$D$3))*((INDIRETTO("I3:I"&$D$3))=$P3))=0;"";$D$3-MAX(RIF.RIGA(INDIRETTO("$3:$"&$D$3))*((INDIRETTO("I3:I"&$D$3))=$P3)))

Sempre Contr-Maiusc-Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel Problema formula":

Problema Windows 10
Autore: asso1998
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti