Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Numero giorni intervallo tra date suddiviso per mese

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi fox2891 » 23/10/08 14:21

Ciao a tutti,

il mio problema è il seguente:
in Excel, avrei bisogno di una funzione che, dato un intervallo di tempo, mi indichi il numero di giorni SUDDIVISI PER MESE in cui è composto tale intervallo.

Mi spiego meglio con un esempio:
in una cella ho la data 11/01/2007, in un'altra 09/03/2007. Sottraendo la prima alla seconda so che l'intervallo è composto da 57 giorni.
Ecco, io vorrei che questo valore venisse disaggregato mese per mese in automatico, ovvero: dovrebbe venire fuori che dei 57 giorni totali, 20 si riferiscono al mese 1 (gennaio), 28 al mese 2 (febbraio) e 9 al mese 3 (marzo).

I "subtotali" così creati, 20 28 e 9, mi serviranno poi da inserire in altre formule.

Grazie in anticipo per l'aiuto!

Ciao
Andrea
fox2891
Newbie
 
Post: 4
Iscritto il: 23/10/08 14:06

Sponsor
 

Re: [Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi Anthony47 » 24/10/08 00:46

Ciao fox2891 e benvenuto nel forum.
Non hai spiegato dove questa quantita' ignota di numeri vorresti che sia inserita, quindi lavorero' di mia fantasia.
Supponiamo che hai la data iniziale in A2 e la data finale in B2.
-Da C1 verso destra ti fai una serie 0, 1, 2, 3, etc (lunga quanti mesi vuoi prepararti a gestite come massimo)
-In C2 metti questa formula:
Codice: Seleziona tutto
=SE($B2>=FINE.MESE($A2;C$1);SE(C$1>0;FINE.MESE($A2;C$1)-FINE.MESE($A2;C$1-1);FINE.MESE($A2;C$1)-$A2+1);SE($B2>FINE.MESE($A2;C$1-1);$B2-FINE.MESE($A2;C$1-1);0))

-Copi C2 verso destra per ogni cella che ha una intestazione in riga 1
I numeri che cosi' calcolerai in ogni cella sono quanti giorni del ritardo totale appartengono al mese che rispetto alla data iniziale ha l' offset segnato in riga 1.

Se vuoi che il primo giorno non sia conteggiato, allora aggiungi alla formula in C2 (dopo che l' hai copiata nelle celle adiacenti come te l' ho passata) un "-1" (senza virgolette) in fondo.

Ti quadra per quello che chiedevi e per quello che devi fare?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi tutamimetica » 25/10/08 18:12

Ciao Antony. Per passatempo leggo le varie richieste. Vedo che dai sempre delle ottime risposte a tutti. Ti devo fare i miei complimenti, perchè sei bravissimo.
Sono intervenuto perché ho provato la tua risposta e mi dava la segnalazione di errore #NOME?.
Ho controllato e la funzione FINE.MESE non c'è. Mi puoi consigliare una alternativa?
Un grazie anticipato.
Grazie Tutamimetica
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: [Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi Anthony47 » 26/10/08 00:26

Se ti compare #NOME? allora devi installare il componente aggiuntivo Strumenti di analisi: Menu /Strumenti /Componenti aggiuntivi; spunti la voce "Strumenti di analisi", Ok.

Fai sapere, ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi tutamimetica » 26/10/08 07:34

Grazie della risposta. Domani seguirò il tuo consiglio, oggi mi è impossibile.
Io intanto avevo risolto parzialmente il problema così:
A1 inserisco la data di partenza – A2 inserisco la data di arrivo
A partire da J1 inserisco una tabella di ausilio ove quella b sta per gli anni bisestili
b
0
1 gennaio 31
2 febbraio 29
3 marzo 31
4 aprile 30
5 maggio 31
6 giugno 30
7 luglio 31
8 agosto 31
9 settembre 30
10 ottobre 31
11 novembre 30
12 dicembre 31

A partire da C5
Progressivo
=MESE(A2)
=SE(C6=0;0;SE(MESE($B$2)=C6;0;SE(MESE($B$2)>C6;C6+1;MESE($B$2))))
=SE(C7=0;0;SE(MESE($B$2)=C7;0;SE(MESE($B$2)>C7;C7+1;MESE($B$2))))
=SE(C8=0;0;SE(MESE($B$2)=C8;0;SE(MESE($B$2)>C8;C8+1;MESE($B$2))))
=SE(C9=0;0;SE(MESE($B$2)=C9;0;SE(MESE($B$2)>C9;C9+1;MESE($B$2))))
=SE(C10=0;0;SE(MESE($B$2)=C10;0;SE(MESE($B$2)>C10;C10+1;MESE($B$2))))
=SE(C11=0;0;SE(MESE($B$2)=C11;0;SE(MESE($B$2)>C11;C11+1;MESE($B$2))))
=SE(C12=0;0;SE(MESE($B$2)=C12;0;SE(MESE($B$2)>C12;C12+1;MESE($B$2))))
=SE(C13=0;0;SE(MESE($B$2)=C13;0;SE(MESE($B$2)>C13;C13+1;MESE($B$2))))
=SE(C14=0;0;SE(MESE($B$2)=C14;0;SE(MESE($B$2)>C14;C14+1;MESE($B$2))))
=SE(C15=0;0;SE(MESE($B$2)=C15;0;SE(MESE($B$2)>C15;C15+1;MESE($B$2))))
=SE(C16=0;0;SE(MESE($B$2)=C16;0;SE(MESE($B$2)>C16;C16+1;MESE($B$2))))

A partire da D5
mese
=CERCA.VERT(C6;$J$2:$L$14;2)
=CERCA.VERT(C7;$J$2:$L$14;2)
=CERCA.VERT(C8;$J$2:$L$14;2)
=CERCA.VERT(C9;$J$2:$L$14;2)
=CERCA.VERT(C10;$J$2:$L$14;2)
=CERCA.VERT(C11;$J$2:$L$14;2)
=CERCA.VERT(C12;$J$2:$L$14;2)
=CERCA.VERT(C13;$J$2:$L$14;2)
=CERCA.VERT(C14;$J$2:$L$14;2)
=CERCA.VERT(C15;$J$2:$L$14;2)
=CERCA.VERT(C16;$J$2:$L$14;2)
=CERCA.VERT(C17;$J$2:$L$14;2)

A partire E5
gg
=CERCA.VERT(C6;$J$2:$L$14;3)-GIORNO($A$2)
=SE(MESE($B$2)=C7;GIORNO($B$2);CERCA.VERT(C7;$J$2:$L$14;3))
=SE(MESE($B$2)=C8;GIORNO($B$2);CERCA.VERT(C8;$J$2:$L$14;3))
=SE(MESE($B$2)=C9;GIORNO($B$2);CERCA.VERT(C9;$J$2:$L$14;3))
=SE(MESE($B$2)=C10;GIORNO($B$2);CERCA.VERT(C10;$J$2:$L$14;3))
=SE(MESE($B$2)=C11;GIORNO($B$2);CERCA.VERT(C11;$J$2:$L$14;3))
=SE(MESE($B$2)=C12;GIORNO($B$2);CERCA.VERT(C12;$J$2:$L$14;3))
=SE(MESE($B$2)=C13;GIORNO($B$2);CERCA.VERT(C13;$J$2:$L$14;3))
=SE(MESE($B$2)=C14;GIORNO($B$2);CERCA.VERT(C14;$J$2:$L$14;3))
=SE(MESE($B$2)=C15;GIORNO($B$2);CERCA.VERT(C15;$J$2:$L$14;3))
=SE(MESE($B$2)=C16;GIORNO($B$2);CERCA.VERT(C16;$J$2:$L$14;3))
=SE(MESE($B$2)=C17;GIORNO($B$2);CERCA.VERT(C17;$J$2:$L$14;3))

Mi sembra che funzioni.
Non funziona se le date sono a cavallo di due anni e naturalmente non mi riesce risolvere questo inconveniente.
Grazie e buona domenica.
Tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: [Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi fox2891 » 27/10/08 14:57

Ok, grazie a tutti e due :D
fox2891
Newbie
 
Post: 4
Iscritto il: 23/10/08 14:06

Re: [Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi tutamimetica » 27/10/08 18:28

Fox
ho risolto anche il conteggio delle date a cavallo di due anni
sostituisci la parte a partire da C5 con
Progressivo
=MESE(A2)
=SE(C6=0;0;SE(C6=12;1;SE(MESE($B$2)=C6;0;SE(MESE($B$2)>C6;C6+1;MESE($B$2)))))
=SE(C7=0;0;SE(C7=12;1;SE(MESE($B$2)=C7;0;SE(MESE($B$2)>C7;C7+1;MESE($B$2)))))
=SE(C8=0;0;SE(C8=12;1;SE(MESE($B$2)=C8;0;SE(MESE($B$2)>C8;C8+1;MESE($B$2)))))
=SE(C9=0;0;SE(C9=12;1;SE(MESE($B$2)=C9;0;SE(MESE($B$2)>C9;C9+1;MESE($B$2)))))
=SE(C10=0;0;SE(C10=12;1;SE(MESE($B$2)=C10;0;SE(MESE($B$2)>C10;C10+1;MESE($B$2)))))
=SE(C11=0;0;SE(C11=12;1;SE(MESE($B$2)=C11;0;SE(MESE($B$2)>C11;C11+1;MESE($B$2)))))
=SE(C12=0;0;SE(C12=12;1;SE(MESE($B$2)=C12;0;SE(MESE($B$2)>C12;C12+1;MESE($B$2)))))
=SE(C13=0;0;SE(C13=12;1;SE(MESE($B$2)=C13;0;SE(MESE($B$2)>C13;C13+1;MESE($B$2)))))
=SE(C14=0;0;SE(C14=12;1;SE(MESE($B$2)=C14;0;SE(MESE($B$2)>C14;C14+1;MESE($B$2)))))
=SE(C15=0;0;SE(C15=12;1;SE(MESE($B$2)=C15;0;SE(MESE($B$2)>C15;C15+1;MESE($B$2)))))
=SE(C16=0;0;SE(C16=12;1;SE(MESE($B$2)=C16;0;SE(MESE($B$2)>C16;C16+1;MESE($B$2)))))
ciao tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: [Excel] Numero giorni intervallo tra date suddiviso per mese

Postdi tutamimetica » 27/10/08 19:03

Per errore ho inserito errato
quello esatto è
=MESE(A2)
=SE(C6=0;0;SE(C6=12;1;SE(MESE($B$2)=C6;0;C6+1)))
=SE(C7=0;0;SE(C7=12;1;SE(MESE($B$2)=C7;0;C7+1)))
=SE(C8=0;0;SE(C8=12;1;SE(MESE($B$2)=C8;0;C8+1)))
=SE(C9=0;0;SE(C9=12;1;SE(MESE($B$2)=C9;0;C9+1)))
=SE(C10=0;0;SE(C10=12;1;SE(MESE($B$2)=C10;0;C10+1)))
=SE(C11=0;0;SE(C11=12;1;SE(MESE($B$2)=C11;0;C11+1)))
=SE(C12=0;0;SE(C12=12;1;SE(MESE($B$2)=C12;0;C12+1)))
=SE(C13=0;0;SE(C13=12;1;SE(MESE($B$2)=C13;0;C13+1)))
=SE(C14=0;0;SE(C14=12;1;SE(MESE($B$2)=C14;0;C14+1)))
=SE(C15=0;0;SE(C15=12;1;SE(MESE($B$2)=C15;0;C15+1)))
=SE(C16=0;0;SE(C16=12;1;SE(MESE($B$2)=C16;0;C16+1)))
Chiedo scusa
tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Numero giorni intervallo tra date suddiviso per mese":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti