Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL - Macro Subtotali con formattazione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL - Macro Subtotali con formattazione

Postdi Flash30005 » 16/09/08 14:43

Con questa semplice macro ottengo dei subtotali di un foglio di excel ma vorrei che anche il valore del subtotale fosse in grassetto come la scritta "Totale" o "Totale Complessivo"

Codice: Seleziona tutto
    Selection.Subtotal GroupBy:=4, Function:=xlSum, TotalList:=Array(7, 9, 11, _
        12), Replace:=False, PageBreaks:=False, SummaryBelowData:=True

Con la macro ottengo appunto:
Totale 1,1 50 274 208
...
...
Totale complessivo 1,86 129 751 690

Quale codice e dove inserirlo per avere anche i valori della somma in grassetto? Al fine di rendere il foglio più leggibile?
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Sponsor
 

Re: EXCEL - Macro Subtotali con formattazione

Postdi Anthony47 » 16/09/08 15:07

Non so se lo puoi fare da codice, potresti provare con una formattazione condizionale, con la formula
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("Totale";$A1));0;1)

Come formattazione inserisci il grassetto o quello che piu' ti aiuta.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: EXCEL - Macro Subtotali con formattazione

Postdi Flash30005 » 17/09/08 11:23

Le soluzioni semplici... sono sempre le migliori, grazie Anthony!

Posto, ora, con piacere una "chicca" per coloro che usano molto i subtotali in una tabella di excel.

Come sapete i subtotali vengono calcolati ad ogni cambiamento di un determinato campo e permette di fare diverse funzioni (Somma, Conteggio, Media, Conta Num etc) ma ammettiamo che si hanno delle colonne delle quali si deve fare una Media in un'altra colonna un Conta Numeri e in un'altra ancora una Somma. In questo caso bisogna ripetere i subtotali per ogni funzione voluta e quindi si avranno 3 righe di subtotali ad ogni interruzione del campo 1 (es. data nella colonna A).
Questa soluzione non mi soddisfaceva molto e così ho realizzato una macro che crea in una unica riga i subtotali con funzioni diverse (Es. G=Media, I=Conta Numeri, K=Somma):
Codice: Seleziona tutto
'Questo codice crea un semplice subtotale con la funzione Somma per le tre colonne G, I, K (corrispondenti a 7, 9, 11)
 Selection.Subtotal GroupBy:=1, Function:=xlSum, TotalList:=Array(7, 9, 11), _
        Replace:=False, PageBreaks:=False, SummaryBelowData:=True
   
' Il seguente codice macro sostituisce (cercando su tutta la colonna G la "stringa nella formula "=SUBTOTALE(9:" dove 9 corrisponde alla Somma) e sostituisce la stringa con "=SUBTOTALE(1;" dove 1 corrisponde alla Media
    Columns("G:G").Select
    Selection.Replace What:="=SUBTOTALE(9;", Replacement:="=SUBTOTALE(1;", _
        LookAt:=xlPart, SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:= _
        False, ReplaceFormat:=False

' Il seguente codice macro sostituisce invece (cercando su tutta la colonna I la "stringa nella formula "=SUBTOTALE(9:" dove 9 corrisponde alla Somma) e sostituisce la stringa con "=SUBTOTALE(2;" dove 2 corrisponde a Conta Num
    Columns("I:I").Select
    Selection.Replace What:="=SUBTOTALE(9;", Replacement:="=SUBTOTALE(2;", _
        LookAt:=xlPart, SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:= _
        False, ReplaceFormat:=False


Infine con la "dritta" postata da Anthony che replico:
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("Totale";$A1));0;1)

inserita nella formattazione condizionale delle varie colonne si possono avere sia caratteri grassetto che di diverso colore per differenziare la Media dalla Somma etc. etc.

Cordialmente
am

P.s. Spero solo che tra le migliaia di soluzioni che avete pubblicato non fosse già stata postata (non mi sono letto tutto) semmai potete cancellare questo post
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL - Macro Subtotali con formattazione":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti