Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

come trovare due codici uguali con excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

come trovare due codici uguali con excel

Postdi ginestreto » 16/08/08 10:46

:( ...ho un problema... devo trovare codici uguali tra 2 colonne e riportare il contenuto in un altra colonna . esempio tabella:
codice nominativo citta denominazione codice y nomin y citta y denominaz y
1 a e t 5
3 b p k 1
6 15
23 3
54 92

devo trovare il codice y nella colonna codice e inserire nominativo, citta,denominazione nelle sottostanti colonne : codice y, nomin y, città y , denominaz. y
ho provato con il filtro è troppo lungo il lavoro vorrei fare selezionado l'intera colonna di codice y e tovare il corrispondente nella colonna codici e riportare i contenuti nelle colonne (nomin y.....)
ginestreto
Utente Junior
 
Post: 75
Iscritto il: 18/08/07 11:06

Sponsor
 

Re: come trovare due codici uguali con excel

Postdi Anthony47 » 16/08/08 21:33

Ciao, mi limito a dire "si puo' fare, probabilmente con Cerca.Vert"; purtroppo non hai descritto la tua struttura dati, di piu' non posso fare.
Per la sintassi di Cerca.Vert guarda l' help on line di excel, molto preciso.

Se da questo vago suggerimento non trai lo spunto utile, posta ancora descrivendo pero' la tua struttura dati di partenza.
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: come trovare due codici uguali con excel

Postdi ginestreto » 17/08/08 08:49

:( purtroppo non sono riuscito a spiegarmi bene cmq sia ora allego un doc..zip .....
il mio problema è di selezionare tutta la colonna "g" e trovare i codici uguali nella colonna "a" ed copiare i contenuti delle colonne "b,c,d" nelle colonne "o,p,q" cmq sia vedere allegato e si capirà il tutto :cry:
Allegati

[L’estensione zip è stata disattivata e non puó essere visualizzata.]

ginestreto
Utente Junior
 
Post: 75
Iscritto il: 18/08/07 11:06

Re: come trovare due codici uguali con excel

Postdi Anthony47 » 17/08/08 18:17

Come detto ti aiuta Cerca.Vert:
-in O1 inserisci la formula
Codice: Seleziona tutto
=CERCA.VERT($G1;$A:$D;2;0)

-copia O1 su P1 e Q1, cambiando il "2" in 3 e 4 rispettivamente
-poi copia O1:Q1 in verticale quante sono le voci contenute in col G
Se il risultato e' #N/D significa che la voce in col G manca dall' elenco di col A

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: come trovare due codici uguali con excel

Postdi ginestreto » 18/08/08 14:00

:) :) tutto ok :D :lol: grazie
ginestreto
Utente Junior
 
Post: 75
Iscritto il: 18/08/07 11:06


Torna a Applicazioni Office Windows


Topic correlati a "come trovare due codici uguali con excel":


Chi c’è in linea

Visitano il forum: patel e 10 ospiti