Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] contare presenza di stringa di testo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] contare presenza di stringa di testo

Postdi The_jackal » 09/07/08 12:46

Ciao a Tutti rieccomi sul forum
Ho cercato un po` in giro nel forum ma non ho trovato la risposta...avrei bisogno di poter contare il numero di volte in cui si ripete una determinata stringa di testo unita ad altre parole...esempio
Mela 1
Mela 2
Mela3
Arancio,Mela
Mela9

Io vorrei contare il numero di volte che si presenta mela (5), ma se uso il count if ovviamente mi chiede la stringa esatta...
grazie a tutti
Uso sempre il solito excel 200 in inglese (questo o!!:-((
The_jackal
Utente Junior
 
Post: 21
Iscritto il: 29/05/08 12:16

Sponsor
 

Re: [EXCEL] contare presenza di stringa di testo

Postdi Statix » 09/07/08 13:46

Prova con questa formula
=CONTA.SE(A1:A4;"*mela*")

=COUNT.IF(A1:A4;"*mela*")
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: [EXCEL] contare presenza di stringa di testo

Postdi Anthony47 » 09/07/08 13:51

Se i tuoi dati sono in col A, metti in C1 la stringa che vuoi cercare, poi usi
Codice: Seleziona tutto
=Countif(A:A,"*"&C1&"*")

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] contare presenza di stringa di testo

Postdi Anthony47 » 09/07/08 13:54

...che e' la stessa cosa che ha scritto nel frattempo Statix.

Ri-ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] contare presenza di stringa di testo

Postdi The_jackal » 10/07/08 14:26

Funziona alla grande, quindi per cercare parti di testo e non l`intero contenuto dvo utilizzare la stringa che voglio cercare compresa tra ** giusto?
The_jackal
Utente Junior
 
Post: 21
Iscritto il: 29/05/08 12:16

Re: [EXCEL] contare presenza di stringa di testo

Postdi Statix » 10/07/08 16:42

Ciao, in questa formula al posto di mela inserisci il testo che vuoi cercare


Codice: Seleziona tutto
=COUNT.IF(A1:A4;"*mela*")


mentre in questa formula di Anthony47 puoi digitare il testo da cercare in C1
Codice: Seleziona tutto
=COUNT.IF(A:A,"*"&C1&"*")
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] contare presenza di stringa di testo":


Chi c’è in linea

Visitano il forum: raimea e 6 ospiti