Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL come eliminare le righe che hanno ...

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL come eliminare le righe che hanno ...

Postdi paloma » 24/06/08 08:50

Salve provo a porvi il quesito per vedere se c'è un modo per risparmiare un bel po' di tempo a lavoro:
ho una tabella excel che in colonna a riporta il codice di ciascun cliente e in colonna b, per ciascun cliente, posso trovare o un numero o la sigla ns. se trovo la sigla ns vorrei escludere il cliente eliminando per esempio la riga.
il problema è che i clienti possono avere una, due, tre o più righe cui sono associati testi o numeri e quindi posso avere una, due, tre o più righe associate.
se almeno in una di queste compare il testo ns io vorrei eliminare tutte le righe del cliente.
secondo voi si può fare????
grazie mille!!!!
paloma
Utente Junior
 
Post: 64
Iscritto il: 29/10/07 09:38

Sponsor
 

Re: EXCEL come eliminare le righe che hanno ...

Postdi Flash30005 » 24/06/08 12:08

La maniera più semplice a me sembra quella di applcare un filtro
1) sul menu in alto DATI seleziona Filtro>automatico
2) vedrai che la testata della tua tabella conterrà delle freccette utilizza quella relativa al campo sigla (?) insomma la colonna che contiene ns
3) clicca sulla freccetta e seleziona personalizza
4) si aprirà la maschera del filtro da utilizzare (per default UGUALE) ma tu cambi la condizione in CHE NON CONTIENE sulla sinistra a destra invece scrivi il testo che non deve contenere es. ns clicchi su ok
5) avrai la tabella senza tutte le riche che in quella colonna non hanno ns
Se ti occorre la tabella così fatta ma non filtrata
6) vai sull'angolo in alto a sinistra (della colonna A e sopra la riga 1) del foglio di lavoro (selezioni in pratica tutto il foglio) lo copi e lo incolli in un altro foglio vuoto
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: EXCEL come eliminare le righe che hanno ...

Postdi Flash30005 » 24/06/08 12:11

errata corrige punto 5)
5) avrai la tabella senza tutte le righe che contengono ns
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: EXCEL come eliminare le righe che hanno ...

Postdi paloma » 24/06/08 12:14

Flash30005 ha scritto:errata corrige punto 5)
5) avrai la tabella senza tutte le righe che contengono ns

intanto grazie mille per la risposta,
ma io vorrei eliminare non solo le righe che contengono NS ma anche tutte quelle relative al cliente che potrebbe avere anche un solo NS. Provo a spiegarmi meglio:

la mia tabella prevede:

Rossi 2
Rossi 3
Rossi NS
Verdi 1
Bruni 4
Bruni NS
Marroni 2

In questo caso se io imposto una formula selezionando le righe con NS rischierei di estrarre solo:
Rossi NS
Bruni NS

Mentre io vorrei invece ottenere il seguente risultato:
Rossi 2
Rossi 3
Rossi NS
Bruni 4
Bruni NS

:?: :?: :?:
paloma
Utente Junior
 
Post: 64
Iscritto il: 29/10/07 09:38

Re: EXCEL come eliminare le righe che hanno ...

Postdi Flash30005 » 24/06/08 12:38

Da quello che specifichi per iscritto sembra che tu debba togliere le righe e tutti i clienti che hanno almeno una cella NS
quindi sembrerebbe che il risultato debba essere:
Verdi 1
Marroni 2

dall'esempio riportato invece il risultato è il contrario
"Mentre io vorrei invece ottenere il seguente risultato:
Rossi 2
Rossi 3
Rossi NS
Bruni 4
Bruni NS "

In ogni caso credo occorra una macro da sviluppare

nel frattempo sarebbe opportuno specificare quello che vuoi ottenere
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: EXCEL come eliminare le righe che hanno ...

Postdi paloma » 24/06/08 13:48

'azz hai ragione!!!
diciamo che l'obiettivo finale in effetti sarebbe quello di estrarre tutti quei clienti che hanno almeno una riga in cui compare il codice NS riportando tutte le righe di tali clienti e quindi confermo che mi aspetterei di ottenere
Rossi 2
Rossi 3
Rossi NS
Bruni 4
Bruni NS :oops:
paloma
Utente Junior
 
Post: 64
Iscritto il: 29/10/07 09:38

Re: EXCEL come eliminare le righe che hanno ...

Postdi Anthony47 » 24/06/08 14:08

In C1:
Codice: Seleziona tutto
=SE(B1="ns";A1;"")

In D1:
Codice: Seleziona tutto
=SE(CONTA.SE(C:C;A1)>0;1;"")

Poi copi C1:D1 verso il basso per coprire (o superare) le tue righe
Applichi un filtro automatico su colonna D (selezioni colonna, Menu /Dati /Filtro /Filtro automatico), scegli 1 dall' elenco che ti compare quando clicchi sul simbolo del filtro.
A questo punto visualizzi solo i nominativi che hanno almeno un NS; non ho capito l' uso che devi fare del risultato, eventualmente filtri "l' opposto" a quello che cerchi, selezioni tutte le righe che ti presenta, Menu /Modifica /Elimina righe; le righe vengono eliminate dal tuo elenco; per vedere cio' che resta sceglierai "(Tutto)" nel filtro automatico.

Oltre le solite copie di backup del tuo file, in questo caso suggerisco di fare l' operazione su una copia del tuo foglio: Menu /Modifica /Sposta o copia foglio, poi spunti la voce "Crea una copia" e chiudi con Ok.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: EXCEL come eliminare le righe che hanno ...

Postdi paloma » 24/06/08 16:29

Grandisssssimo Anthony47, ottimo funziona perfettamente!
Complimenti sei sempre una garanzia!
Ciao ciao ;) ;)
paloma
Utente Junior
 
Post: 64
Iscritto il: 29/10/07 09:38


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL come eliminare le righe che hanno ...":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti