Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] conta se con due criteri

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] conta se con due criteri

Postdi The_jackal » 10/06/08 09:50

Ciao a tutti mi rivolgo ancora al forum per un piccolo problema...
Colonna B colonna C
Mela 3
Pera 0
Arancio 1
Mela 1
Mela 0
Arancio 1

Vorrei ottnenere due risultati:
Il totale dei valori associati a mela (4) e questo lo posso fare con un sum if
Ma non so come contre il numero di celle con valore superiore a 0 associate a mela...ho provato a usare un IF associato a un count if...ma non riesco...so che deve essere abbasanza semplice ma non riesco a combinare le cose
grazie a tutti
The_jackal
Utente Junior
 
Post: 21
Iscritto il: 29/05/08 12:16

Sponsor
 

Re: [Excel] conta se con due criteri

Postdi Anthony47 » 10/06/08 13:28

Prova
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((B1:B10="Mela")+0;(C1:C10>0)+0)

(col traduttore automatico diventa =SUMPRODUCT((B1:B10="Apple")+0,(C1:C10>0)+0) ... :D )

Vedi anche viewtopic.php?f=26&t=49938
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] conta se con due criteri

Postdi The_jackal » 10/06/08 14:55

Ok quindi per contare le celle con piu` critri uso la matrice somma prodoto e ovviamente li si possono aggiungere anche altri parametri...

Non avevo visto l`altro 3d, che mi sarebbe stato d`aiuto....

Grazie mille
The_jackal
Utente Junior
 
Post: 21
Iscritto il: 29/05/08 12:16


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] conta se con due criteri":


Chi c’è in linea

Visitano il forum: albval, patel e 23 ospiti