Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel Formula somma e sostituisci a condizione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel Formula somma e sostituisci a condizione

Postdi Statix » 31/05/08 15:37

Ciao questa è bella tosta,(parlo per me,che sono agli albori)


in A1: A50 ho dei valori 1 e valori 0

vorrei contare gli 1 partendo da A50 a A1,(dal basso in alto)cella x cella
arrivati alla somma 10 convertirlo in A ,
con il prossimo incremento di + 1 (11=B)
e cosi via,con una condizione che una volta arrivato a R (25 = R) si azzeri la conta
e ripartire a contare di nuovo con la successiva cella che contiene 1

La formula deve contare,arrivata a 10 sostituire il numero in lettera corrispondente alla tabella,una volta arrivata a R ,azzerare la conta e ripartire con la successiva.

Codice: Seleziona tutto
Tabella
10 = A
11 = B
12 = C
13 = D
14 = E
15 = F
16 = G
17 = H
18 = I
19 = L
20 = M
21 = N
22 = O
23 = P
24 = Q
25 = R


esempio di conteggio con sostituzione partendo da A50 ad A1
Codice: Seleziona tutto
A1=1   in C1=G   
A2=0   in C2=
A3=1   in C3=F
A4=1   in C4=E
A5=1   In C5=D
A6=0   in C6=
A7=1   in C7=C
A8=0   in C8=
A9=1   in C9=B
A10=1  in C10=A
A11=0  in C11=
A12=1  in C12=9
A13=0  in C13=
A14=1  in C14=8
A15=1  in C15=7
A16=0  in C16=
A17=1  in C17=6
A18=1  in C18=5
A19=1  in C19=4
A20=0  in C20=
A21=1  in C21=3
A22=1  in C22=2
A23=0  In C23=
A24=0  in C24=
A25=1  in C25=1
A26:A50=1 In C26=R (nel range A26:A59 ci sono tutti 1)

questa formula la dovrò applicare successivamente ad altre colonne( per la precisione 90 colonne e 50 a 100 righe)
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Excel Formula somma e sostituisci a condizione

Postdi Anthony47 » 31/05/08 22:57

E’ solo un gioco di pazienza per annidare una funzione dopo l’ altra.
In una zona libera crei la tabella con le equivalenze Numero/Lettera (quella che hai postato); per R userai pero’ 0 invece di 25. Poi assegni all’ area (16 righe*2 colonne) il nome “Tabella”.
Quindi in C1 userai la formula
Codice: Seleziona tutto
=SE(A1>0;SE(O((RESTO(CONTA.SE(A1:A$50;1);25))>9;(RESTO(CONTA.SE(A1:A$50;1);25))=0);CERCA.VERT(RESTO(CONTA.SE(A1:A$50;1);25);Tabella;2;0);RESTO(CONTA.SE(A1:A$50;1);25));"")

Infine copierai la formula fino a C50.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel Formula somma e sostituisci a condizione

Postdi Statix » 31/05/08 23:44

Ciao Anthony47
tutto ok,sei fantastico
mille ringraziamenti,
spero di non annoiarti con le mie idee balorde sul gioco del lotto,con formule strambe.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel Formula somma e sostituisci a condizione

Postdi Statix » 01/06/08 11:42

Ciao Anthony47
mi è sorto un nuovo problema,se nella range A1:A50 ho degli 1 e degli spazi la formula non funziona bene,onde evitare di riconvertire gli spazi con 0,avevo provato ad aggiungere alla formula

=SE(E(LUNGHEZZA(C1)>0;LUNGHEZZA(A1)>0)

come postato per una formula precedente,ma non ci riesco.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel Formula somma e sostituisci a condizione

Postdi Anthony47 » 01/06/08 22:16

Se non hai solo 1 e 0, ma il concetto del conteggio degli 1 rimane, allora usa questa variante della formula:
Codice: Seleziona tutto
=SE(A1=1;SE(O((RESTO(CONTA.SE(A1:A$50;1);25))>9;(RESTO(CONTA.SE(A1:A$50;1);25))=0);CERCA.VERT(RESTO(CONTA.SE(A1:A$50;1);25);Tabella;2;0);RESTO(CONTA.SE(A1:A$50;1);25));"")


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel Formula somma e sostituisci a condizione":


Chi c’è in linea

Visitano il forum: wallace&gromit e 13 ospiti