Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

#N/A in Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

#N/A in Excel

Postdi al3ssio » 21/05/08 12:06

Buongiorno a tutti,

avrei una domandina inerente excel: se ho una colonna con valori ed alcuni #N/A derivanti da un cerca.verticale e voglio, ad esempio nella colonna accanto, un "if" che mi mette al posto degli #N/A una frase tipo "Elemento non trovato" , come faccio?

Come faccio ad esprimere l' #N/A nella condizione? Se lo metto tra apici non funziona.

Spero di essermi spiegato.

Vi ringrazio anticipatamente,

Alessio
al3ssio
Utente Senior
 
Post: 234
Iscritto il: 08/05/04 15:59

Sponsor
 

Re: #N/A in Excel

Postdi Anthony47 » 21/05/08 13:48

Puoi usare SE(VAL.NON.DISP(A1);etc etc) [IF(ISNA(A1),etc etc) per la versione inglese] o piu’ genericamente VAL.ERRORE(A1) [ISERROR(A1)].
Ovviamente puoi usare questa funzione insieme al Cerca.Vert per avere direttamente il risultato o il messaggio, ad esempio
Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT(A1;L1:N12;3;0));"Valore non in tabella";CERCA.VERT(A1;L1:N12;3;0))


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: #N/A in Excel

Postdi al3ssio » 24/05/08 13:05

Grazie Anthony!
E' proprio quello che cercavo, a me serviva qualcosa di specifico per l'errore #N/A e non credevo esistesse!

Alessio
al3ssio
Utente Senior
 
Post: 234
Iscritto il: 08/05/04 15:59


Torna a Applicazioni Office Windows


Topic correlati a "#N/A in Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti