Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Funzione per fare uscire nel risultato anche del testo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Funzione per fare uscire nel risultato anche del testo

Postdi papclems » 09/05/08 09:35

Ho cercato di mettere il titolo più chiaro possibile.

allora, nel foglio www.papclems.com/fantanba/RostersLega1.xls nella pagina "Rosters"

ho le squadre, con nelle varie colonne il ruolo (G,A,C) il Nome del giocatore, e poi due colonne (contratto "C", e Durata "D" ).

Nella cella in fondo ad ogni squadra (cella che ho unito) vorrei inserire una formula che mi calcola la somma dei contratti ancora in essere (quindi sono quelli che in D anno almeno 1 (cioè l'anno di durata) e non mi calcoli quindi quelli con 0 ).

Questa formula però non deve darmi solo il risultato ma vorrei che nella cella in fondo uscisse una cosa come
Total Salary = "la somma dei contratti in essere" Under Cap = "la differenza fra la somma e 120"

:D

E' una cosa fattibile?
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Sponsor
 

Re: Funzione per fare uscire nel risultato anche del testo

Postdi archimede » 09/05/08 17:37

Codice: Seleziona tutto
="Total Salary = " & SUM(A1:A2) & " Under Cap = " & SUM(A1:A2) - 120
HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Re: Funzione per fare uscire nel risultato anche del testo

Postdi papclems » 09/05/08 19:02

archimede ha scritto:
Codice: Seleziona tutto
="Total Salary = " & SUM(A1:A2) & " Under Cap = " & SUM(A1:A2) - 120
HTH.

Alessandro



grazie mille Alessandro.

al momento la foruma che mi suggerisci però mi da errore, l'errore #NOME .

Inoltre vedo che è A1:A2 ma il calcolo che voglio io deve comprendere tutta la colonna C nelle caselle da 8 a 27 (sono quelle che devono sommarsi).
Però si devono sommare solo se nella casella D non c'è zero. Altrimenti non va sommata.
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Re: Funzione per fare uscire nel risultato anche del testo

Postdi archimede » 09/05/08 19:48

A1:A2 era solo un esempio: va da sè che devi mettere il range di caselle che ti interessa. Ad esempio:
Codice: Seleziona tutto
=SOMMA.SE(D8:D27;">0";C8:C27)
HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Re: Funzione per fare uscire nel risultato anche del testo

Postdi papclems » 09/05/08 20:09

Scusami ma probabilmente la stanchezza mi rende ottuso (oggi iperlavoro :D ).

Non riesco a far funzionare quella formula.
io l'ho inserita così
Codice: Seleziona tutto
 ="Total Salary = " & SOMMA.SE(D8:D27;">0";C8:C27) & " Under Cap = " & SOMMA.SE(D8:D27;">0";C8:C27) - 120


ma mi da errore.

ho provato ad inserire solo
Codice: Seleziona tutto
=SOMMA.SE(D8:D27;">0";C8:C27)


ma in quel caso mi da 0 come risultato.

Il foglio è www.papclems.com/fantanba/RostersLega1.htm (per vederlo) e praticamente il totale della prima squadra (i Chupacabras Milano)dovrebbe invece essere 64 in Total salary e 56 in Under Cap
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Re: Funzione per fare uscire nel risultato anche del testo

Postdi Anthony47 » 10/05/08 02:01

Stai sbagliando i nomi delle colonne, perche’ nelle formule C e D sono i nomi delle colonne non le intestazioni Contratto e Durata che tu hai asegnato...

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Funzione per fare uscire nel risultato anche del testo

Postdi papclems » 10/05/08 14:10

chiedo scusa, come sempre avete ragione, grazie alessandro :D

Ero proprio fuso ieri non m'ero per niente accorto che inserivo le lettere C e D invece che E e D :oops:
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48


Torna a Applicazioni Office Windows


Topic correlati a "Funzione per fare uscire nel risultato anche del testo":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti