Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

collegare un colore ad una somma e lista da sommare

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

collegare un colore ad una somma e lista da sommare

Postdi ialma » 02/05/08 10:36

Ciao a tutti!
Esiste un modo per far visualizzare in un altro colore le colonne che fanno riferimento ad una casella SOMMA ?
in una funzione come =SOMMA(N23:N54) far si che ad esempio la casella della somma e quelle da n23 a n54 siano dello stesso colore ?
In database con molte modifiche, di solito inserimenti in cima alla lista non si aggiungono alla somma automatica finale.
Grazie a chi risponderà :-)
ialma
Utente Junior
 
Post: 13
Iscritto il: 04/01/08 16:45

Sponsor
 

Re: collegare un colore ad una somma e lista da sommare

Postdi Anthony47 » 02/05/08 23:45

Ciao ialma e benvenuto nel forum.

Il sistema piu' veloce e' il seguente:
-alle celle che userai assegni un nome, es gruppo1 (seleziona le celle, Menu /Inserisci /Nome /Definisci; scrivi gruppo1 e chiudi con Ok)
-quindi userai la formula =SOMMA(gruppo1)
-infine carichi questa macro nel "modulo di codice del foglio su cui lavori"
Codice: Seleziona tutto
Private Sub Worksheet_Change(ByVal Target As Range)
Range("gruppo1").Interior.ColorIndex = 3 '<<< 3=ROSSO; 4=Verde; 6=Giallo;7=Fucsia; 8=Celeste
End Sub

Per questo: tasto dx sul tab col nome del foglio su cui lavori, si apre l' editor del vba, copi il codice e lo incolli nel frame di destra.

In questo modo ogni volta che viene fatto un cambiamento sul foglio le celle che appartengono a gruppo1 e che quindi fanno parte della somma vengono colorate.
La cella con la formula la colorerai "a mano" (Menu /Format /Celle)

Per evitare all' origine il problema, io inserisco sopra e sotto l' elenco una cella con la scritta "inizio lista" e "fine lista" e includo queste celle nella formula (o alle celle che ho nominato "gruppo1"); in questo modo l' utente e' portato a inserire righe solo nelle posizioni accettate dalla formula.

Se hai bisogno di altro, posta ancora.
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "collegare un colore ad una somma e lista da sommare":


Chi c’è in linea

Visitano il forum: jos235, papiriof e 13 ospiti