Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Numeri pari e dispari da sommare

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Numeri pari e dispari da sommare

Postdi luigi99 » 15/02/08 17:31

Eccoci qua con un altro quesito:
ho delle serie di numeri composti da 10/12 numeri, le stesse sono composte di numeri pari e dispari mescolati:
1-2-8-43-14-77-96-127-128
5-3-44-81-6-57-174-12-99
Devo fare la somma dei numeri pari e dei numeri dispari separatamente.
Ho provato con SE, ma non sono approdato a niente, PARI non mi sembra possa servire e così anche CONTA SE.
Dovrei probabilmente ricorrere ad una macro creata con visual basic, ma è a ldi fuori della mia portata.
Si può fare però?
Grazie ciao.
Luigi
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese

Sponsor
 

Re: Numeri pari e dispari da sommare

Postdi Dylan666 » 15/02/08 18:04

Dividi il numero per due e vedi se dà il resto oppure no.
Se non lo dà capisci che è pari, altrimenti è dispari.

Codice: Seleziona tutto
=SE((RESTO(B1;2))=0;"Il numero è pari";"Il numero è dispari")


http://blog.shareoffice.it/emanuele/arc ... /5354.aspx
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Numeri pari e dispari da sommare

Postdi Anthony47 » 15/02/08 18:18

Oppure, senza disturbare i guru, se i tuoi dati sono in A1:A20, puoi direttamente sommare:
Per i dispari
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(A1:A20;(INT(A1:A20/2)<>(A1:A20/2))*1)

Per i pari
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(A1:A20;(INT(A1:A20/2)=(A1:A20/2))*1)


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Numeri pari e dispari da sommare

Postdi luigi99 » 16/02/08 00:35

Anthony47 ha scritto:Oppure, senza disturbare i guru, se i tuoi dati sono in A1:A20, puoi direttamente sommare:
Per i dispari
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(A1:A20;(INT(A1:A20/2)<>(A1:A20/2))*1)

Per i pari
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(A1:A20;(INT(A1:A20/2)=(A1:A20/2))*1)


Ciao.


PERFETTO (come sempre!!)
ho solo cambiato i riferimenti da verticale a orizzontale e ho avuto i risultati in un attimo :lol: :lol:
Grazie.
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese


Torna a Applicazioni Office Windows


Topic correlati a "Numeri pari e dispari da sommare":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti