Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] Probl: differenza fra date/ore in un intervallo noto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi marcomarco » 29/12/07 20:36

Buonasera a tutti.
è un pomeriggio che ci ragiono ma non ce ne vengo ad una.

il mio problema è questo: ho data e ora di partenza e arrivo di un treno; oltre a calcolare la durata dello spostamento dovrei anche sapere quante ore di quello spostamento rientrano in un intervallo orario noto/pre-definito (impostato tramite due variabili).

esempio pratico:
dati
- cella[A1]-> 25/12 20:38 (partenza)
- cella[A2]-> 26/12 09:00 (arrivo)
- definizione periodo di tempo "trascorso di notte":
... cella[A4]-> 19:00
... cella[A5]-> 05:00
richieste
- durata totale dello spostamento -> risolvibile con formula =(A2-A1)
- durata dello spostamento "notturno" (cioè quello compreso fra le 19:00 e le 05:00) -> ???

c'è qualcuno più scaltro di me che ha una soluzione? non sembrerebbe troppo difficile ma ammetto che non ci arrivo proprio :cry:
marcomarco
Utente Junior
 
Post: 32
Iscritto il: 29/12/07 20:10

Sponsor
 

Re: [EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi Anthony47 » 29/12/07 23:39

Ciao marco, benvenuto nel forum e complimenti per i contributi che vedo numerosi.
Prova questa formula:
Codice: Seleziona tutto
=SE(E(A2>=(INT(A2)+A5);A1<=(INT(A1)+A4));(INT(A2)+A5)-(INT(A1)+A4);SE(E(A2>=(INT(A2)+A5);A1<(INT(A2)+A5));(INT(A2)+A5)-A1;SE(A2>=(INT(A1)+A4);A2-(INT(A1)+A4)-SE(A1>(INT(A1)+A4);A1-(INT(A1)+A4);0))))


Fai sapere se ti quadra, ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi marcomarco » 05/01/08 20:36

innanzitutto grazie 1000 per la celerità!

sulla formula funziona... l'unica cosa che a volte mi restituisce o falso oppure zero. falso è corretto se il treno parte e arriva fuori dalle fasce "notturne". mentre 0:00 non capisco bene dove lo calcoli. di primo acchito mi sembrerebbe che se il treno parte per esempio di pomeriggio e termina per esempio alle 24 mi calcoli 0.
provo a fare qualche verifica in più e nel caso smentisco o confermo ;)
marcomarco
Utente Junior
 
Post: 32
Iscritto il: 29/12/07 20:10

Re: [EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi Anthony47 » 06/01/08 00:17

Non stare a debuggare la formula; poiche’ mi vergognavo della complessita’ ne avevo cercata una piu’ semplice che pero’ non avevo postato:
Codice: Seleziona tutto
=SE(A2>(INT(A1)+A4);A2-(INT(A1)+A4)-SE(A2>(INT(A2)+A5);A2-(INT(A2)+A5);0);0)-SE(A1>(INT(A1)+A4);A1-(INT(A1)+A4);0)


Provala e fai sapere. Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi marcomarco » 06/01/08 11:31

ancora grazie!

dunque, con questa l'unico problema sta qua:
treno che parte di giorno e termina entro la mezzanotte O treno che parte e arriva nella fascia notturna entro la mezzanotte. in questi casi mi viene restituito #######.

esempio del caso 1:
P: 11/7 17:27 A: 11/7 19:44
esempio del caso 2:
P: 11/7 20:34 A: 11/7 22:54
entrambi con fascia notturna 19:00 > 05:00

in tutti gli altri correttamente calcolato il tempo, o restituito 0:00 se non rientra nella fascia notturna.

PS: sei un mago di excel! hai la mia ammirazione!
marcomarco
Utente Junior
 
Post: 32
Iscritto il: 29/12/07 20:10

Re: [EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi Anthony47 » 08/01/08 03:20

Mah.. la semplificazione non paga; comunque e’ tutto un gioco di pazienza.
La formula che mi ha dato piu’ soddisfazione (in quano a precisione dei risultati) e’ questa:
Codice: Seleziona tutto
=((A5+INT(A1)+(A5<A4)-((A1-INT(A1))<(A4-0,001))*(A4>0,5))-(A4+INT(A1)-((A1-INT(A1))<(A4-0,001))*(A4>0,5)))-(A2<(A5+INT(A1)+(A5<A4)-((A1-INT(A1))<(A4-0,001))*(A4>0,5)))*((A5+INT(A1)+(A5<A4)-((A1-INT(A1))<(A4-0,001))*(A4>0,5))-A2)-(A1>(A4+INT(A1)-((A1-INT(A1))<(A4-0,001))*(A4>0,5)))*(A1-(A4+INT(A1)-((A1-INT(A1))<(A4-0,001))*(A4>0,5)))+(A1>(A5+INT(A1)+(A5<A4)-((A1-INT(A1))<(A4-0,001))*(A4>0,5)))*(A1-(A5+INT(A1)+(A5<A4)-((A1-INT(A1))<(A4-0,001))*(A4>0,5)))+(A2>((A4+INT(A1)-((A1-INT(A1))<(A4-0,001))*(A4>0,5))+1))*(A2-((A4+INT(A1)-((A1-INT(A1))<(A4-0,001))*(A4>0,5))+1))-(A2>((A5+INT(A1)+(A5<A4)-((A1-INT(A1))<(A4-0,001))*(A4>0,5))+1))*(A2-((A5+INT(A1)+(A5<A4)-((A1-INT(A1))<(A4-0,001))*(A4>0,5))+1))


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi marcomarco » 15/02/08 12:24

scusa se non mi sono più fatto sentire!
cmq funziona ottimamente. non mi ha più dato alcun problema.
grazie 1000 ancora!
marcomarco
Utente Junior
 
Post: 32
Iscritto il: 29/12/07 20:10

Re: [EXCEL] Probl: differenza fra date/ore in un intervallo noto

Postdi Anthony47 » 15/02/08 18:25

marcomarco ha scritto:.... cmq funziona ottimamente. non mi ha più dato alcun problema.
grazie 1000 ancora!
Meno male, seno’ non avrei saputo piu’ da dove cominciare!

Ciao, alla prossima.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] Probl: differenza fra date/ore in un intervallo noto":


Chi c’è in linea

Visitano il forum: Nessuno e 22 ospiti