Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Estrazione dati da un elenco

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Estrazione dati da un elenco

Postdi RMarvin » 09/11/07 11:53

Buongiorno a tutti,
vi presento il mio problema cercando di essere il più chiaro possibile e sperando che qualcuno mi possa aiutare.
Sto creando in Excel un foglio di lavoro simile a un agenda dove nella colonna A si sviluppa l'elenco dei giorni dell'anno 2008 (tipo calendario) mentre nelle altre colonne ci sono una serie di dati che inserisco giorno per giorno. Ho bisogno di creare una piccola tabella riepilogativa nello stesso foglio che mi fornisca le seguenti informazioni:
- Totale dato X di questa settimana
- Totale dato X di questo mese
- Totale dato X di quest'anno
Ho bisogno quindi di un formula che tenga conto della data e che ricavi il totale di un certo dato (esempio distanza percorsa) della settimana corrente, distanza percorsa questo mese e il totale dell'anno 2008.

Ringrazio in anticipo per l'aiuto.
RMarvin
Newbie
 
Post: 3
Iscritto il: 09/11/07 11:36

Sponsor
 

Postdi Anthony47 » 09/11/07 14:57

Puoi semplificare usando 2 colonne per calcolare la settimana e il mese della data, tipo (in B2)
Codice: Seleziona tutto
=SE(A2>0;MESE(A2);"")
e (in C2)
Codice: Seleziona tutto
=SE(A2>0;NUM.SETTIMANA(A2);"")


Poi ottieni i subtotali settimanali con
Codice: Seleziona tutto
=SOMMA.SE(C2:C1000;$K$1;D2:D1000)

e quelli mensili con
Codice: Seleziona tutto
=SOMMA.SE(C2:C1000;$J$1;D2:D1000)

Se tutte le date sono dello stesso anno (come hai detto), il totale annuo e' direttamente
Codice: Seleziona tutto
=SOMMA(D2:D1000)


Le suddette formule ipotizzano che la data sia in A2:A1000, i dati da sommare in D2:D1000, la settimana da filtrare sia in K1, il mese in J1.

Trovi lo spunto?
Ciao, fai sapere.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi RMarvin » 09/11/07 16:34

Grazie mille per l'aiuto!! sono riuscito nell'intento anche se ho cambiato leggermente la procedura che mi hai indicato inquanto non capivo bene i primi due step della tua proceda. Ho creato due colonne nelle quali compaiono in ciascuna cella il numero della settimana e del mese di ogni data:

Codice: Seleziona tutto
=(NUM.SETTIMANA(A2;2))


Codice: Seleziona tutto
=MESE(A2)


Per il resto ho usato il codice da te dato.

Grazie ancora!
RMarvin
Newbie
 
Post: 3
Iscritto il: 09/11/07 11:36

Postdi RMarvin » 09/11/07 17:26

Grazie mille per l'aiuto!! sono riuscito nell'intento anche se ho cambiato leggermente la procedura che mi hai indicato inquanto non capivo bene i primi due step della tua proceda. Ho creato due colonne nelle quali compaiono in ciascuna cella il numero della settimana e del mese di ogni data:


Codice: Seleziona tutto
=(NUM.SETTIMANA(A2;2))




Codice: Seleziona tutto
=MESE(A2)



Per il resto ho usato il codice da te dato.

Grazie ancora!
RMarvin
Newbie
 
Post: 3
Iscritto il: 09/11/07 11:36

Postdi Anthony47 » 09/11/07 19:47

Le formule che avevo dato servivano per poterle inserire anche in righe
non ancora popolate con i tuoi dati.
Ma come hai fatto va bene lo stesso.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Estrazione dati da un elenco":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti