Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

info su excel, Colorazione celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

info su excel, Colorazione celle

Postdi mauweb » 16/10/07 07:56

Ciao a tutti.

Sono nuovo del forum e questo è il mio primo topic.

Volevo farvi una domanda su excel.

cerco di semplificare quello che voglio chiedervi,
ho tre righe di numeri 1, 2, 3,
dove in ogni colonna ci sono valori numerici diversi a, b, c, ecc.
con la funzione se ho fatto in modo che
nella riga 1
se il valore della riga 2 colonna a e inferiore al valore
della riga 3 colonna a
mi scriva il valore della riga 2 colonna a
altrimenti mi scrive il valore della riga 3 colonna a

adesso il quesito,
volevo che quando mi scrive il valore della riga 2 colonna a mi colori il carattere di rosso
mentre se scrive il valore della riga 3 colonna a mi colori il carattere di blu.

con la formattazione condizionale so che posso farlo mi toccherebbe farlo casella per casella e sono veramente tante.

è possibile fare questo ?

spero di essermi spiegato.

Ciao.
mauweb
Newbie
 
Post: 4
Iscritto il: 16/10/07 07:45

Sponsor
 

Postdi mauweb » 16/10/07 08:49

a forza di cercare nel forum ho capito che potrei fare così

=SE(V67<V77;V67:colorare();V77)


Function Colorare()
???
End Function

il problema è che non sò cosa scrivere nella function
mauweb
Newbie
 
Post: 4
Iscritto il: 16/10/07 07:45

Postdi Caffey » 16/10/07 13:35

Utilizza titoli descrittivi: rendi la vita più facile a chi sa la risposta! Per maggiori informazioni leggi laNetiquette

La formattazione condizionale la puoi fare anche a gruppi di celle: seleziona tutte quelle a cui la vuoi applicare e poi definiscila.
Al di sopra dell'onnipotenza divina, si erge il più alto potere della ragione [L. A. Feuerbach]
Avatar utente
Caffey
Moderatore
 
Post: 605
Iscritto il: 30/12/06 15:33
Località: Umbria

Postdi mauweb » 16/10/07 17:09

no non la puoi fare perchè se io seleziono le caselle a1 b1 c1
e nella formattazione condizionale
---condizione 1
il valore della cella è uguale a a2 b2 c2
colora di rosso
---condizione 2
il valore della cella è uguale a a3 b3 c3
colora di blu

mi dà errore

per non avere l'errore dovrei casella per casella
---condizione 1
il valore della cella è uguale a a2
colora di rosso
---condizione 2
il valore della cella è uguale a a3
colora di blu

non mi passa più.

ho provato anche a copiare la casella a1 in b1 ma la formula =se( ecc... si aggiorna mentre la formattazione condizionale rimane uguale cioè
---condizione 1
il valore della cella è uguale a a2
colora di rosso
---condizione 2
il valore della cella è uguale a a3
colora di blu

e non

---condizione 1
il valore della cella è uguale a b2
colora di rosso
---condizione 2
il valore della cella è uguale a b3
colora di blu
mauweb
Newbie
 
Post: 4
Iscritto il: 16/10/07 07:45

Postdi Anthony47 » 17/10/07 11:05

La risposta al problema e’ la formattazione condizionale, come gia’ suggerito da Caffey.
Mi pare che hai i dati in orizzontale; probabilmente in A1 hai usato la formula
Codice: Seleziona tutto
=SE(A2<A3;A2;A3)
che poi hai copiato in orizzontale sulle altre celle di riga 1 che ti interessano.

A questo punto selezioni tutte le celle con la formula (es. A1:Z1), poi Menu /Formato /Formattazione condizionale; come condizione 1 scegli “Il valore della cella è”, selezione “uguale a”, digiti “=A2” (senza apici); scegli il formato (rosso) e confermi con Ok; fai “Aggiungi”, e ripeti per aggiungere la seconda condizione con la variante di “=A3” e del colore blu. Chiudi con Ok, e la condizione e’ applicata a tutte le celle in modo relativo.
L’ errore che probabilmente facevi era di usare indirizzi “assoluti”, tipo $A$2.

Potresti anche impostare un’ unica condizione: colori di fisso la cella in blu (Menu /Format /Celle; tab Motivo, assegni il colore) e poi inserisci con la formattazione condizionale solo la condizione del rosso.

Ti torna?
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi mauweb » 18/10/07 08:26

grazie davvero.

ai ragione la formattazione condizionata mi scriveva =$a$1 e non conoscendo bene excel non sapevo degli indirizzi assoluti.
mauweb
Newbie
 
Post: 4
Iscritto il: 16/10/07 07:45


Torna a Applicazioni Office Windows


Topic correlati a "info su excel, Colorazione celle":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti