Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] Funzione particolare

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] Funzione particolare

Postdi misterdv » 03/07/07 14:00

Espongo il mio problema:
ho una tabella nella quale nella prima colonna è presente l'elenco di alcuni nomi [A1:A25]
poinelle 8 colonne successive per ogni nome posso inserire un numero (voto) oppure eventualmente il simbolo "x" che per me rappresenta coloro che in futuro dovranno essere ascoltati (non sono mai più di due, quindi o nel range [B1:H25] ci stanno al più due x e almeno una !!!]
vorrei che in automatico nelle celle b26 e b27 fossero inseriti i NOMI relativemente ai quali è presente la X.... con cerca.vert riesco a farla solo con una "x" .. con due non ci sono riuscito... voi come fareste ???

grazie
misterdv
Newbie
 
Post: 1
Iscritto il: 03/07/07 13:47

Sponsor
 

Postdi Anthony47 » 03/07/07 16:30

Ciao misterdv e benvenuto nel forum.
Io farei cosi’:
-in I1
Codice: Seleziona tutto
=CONTA.SE(B1:H1;"x")>0

-copio I1 nelle celle sottostanti per tutta l’ altezza dei tuoi dati
-in A26
Codice: Seleziona tutto
=SCARTO(A1;CONFRONTA(VERO;I1:I25;0)-1;0)

-in A27
Codice: Seleziona tutto
=SCARTO(A1;CONFRONTA(VERO;SCARTO(I1;CONFRONTA(VERO;I1:I25;0);0;25-SCARTO(I1;CONFRONTA(VERO;I1:I25;0);0));0)+CONFRONTA(VERO;I1:I25;0)-1;0)


Questa seconda formula poteva essere semplificata se certamente la colonna I fosse totalmente libera, ma ho preferito non fare questa assunzione.

Ti torna?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] Funzione particolare":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti