Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Chiarimenti formula SE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Chiarimenti formula SE

Postdi mariojy » 25/09/06 18:30

Salve a tutti,

Per il mio file di gestione del Fantacalcio vorrei sapere cosa inserire nella formula degli intervalli di punteggio dei gol (sottostanti), per far capire al programma Excel che l'intervallo continua all'infinito!

00 |-| 65.5 = 0 gol
66 |-| 68.5 = 1 gol
69 |-| 71.5 = 2 gol
72 |-| 74.5 = 3 gol
75 |-| 77.5 = 4 gol
78 |-| 80.5 = 5 gol
81 |-| 83.5 = 6 gol
84 |-| 86.5 = 7 gol
87 |-| 89.5 = 8 gol
e così via...

Questa è la mia formula:

=SE(G30="";"";SE(G30<66;0;SE(G30<69;1;SE(G30<72;2;SE(G30<75;3;SE(G30<78;4;SE(G30<81;5;SE(G30<84;6;7))))))))

Grazie anticipatamente a tutti!

Mario
mariojy
Newbie
 
Post: 7
Iscritto il: 22/09/06 11:51
Località: Marcianise (CE)

Sponsor
 

Postdi taurex » 26/09/06 08:01

se invece di fare come scrivi tu, semplicemente scrivi nella cella dove vuoi i gol la formula
Codice: Seleziona tutto
=TRONCA(((G30-66)/3)+1;0)
risolvi?
Moderatore di
Immagine
taurex
Utente Senior
 
Post: 145
Iscritto il: 09/08/06 09:34
Località: Asti

[Excel] Chiarimenti formula SE

Postdi mariojy » 26/09/06 08:34

Ti ringrazio taurex,
ma non va. A me non interessa troncare la parte decimale del numero, ma estendere all'infinito la mia formula che fino al punteggio di 83.5 assegna 6 gol e va benissimo! E' dopo che non va in quanto assegna 7 gol per qualsiasi punteggio uguale o superiore a 84 e invece non deve essere così; secondo il nostro schema degli intervalli in breve a 66 fai un gol e poi ogni 3 punti fai un altro gol (quindi 69=2gol; 72=3gol e così via).
Excel ha il limite che in una formula non possono essere inseriti più di 8 SE! Io vorrei comprendere come si fa a far capire ad Excel il mio intervallo all'infinito!

Grazie ancora a tutti anticipatamente,

Mario.
mariojy
Newbie
 
Post: 7
Iscritto il: 22/09/06 11:51
Località: Marcianise (CE)

[Excel] Chiarimenti formula SE

Postdi mariojy » 26/09/06 16:20

Raga HO RISOLTO DA ME!!!

Bisognava usare la formula CONTA.SE e mettere il mio intervallo su un altro foglio di lavoro (Foglio2); questa è la mia formula:

=SE(C30<=0;"";CONTA.SE(Foglio2!A01:A20;"<="&C30))

La cella C30 è quella che contiene il valore/punteggio da tramutare in gol.

Questa è la colonna di valori che ho messo nel Foglio2 (celle da A01 a A20)

66
69
72
75
78
81
84
87
90
93
96
99
102
105
108
111
114
117
120
123

Così ho attenuto ciò che volevo!

Grazie a tutti comunque!

Mario.
mariojy
Newbie
 
Post: 7
Iscritto il: 22/09/06 11:51
Località: Marcianise (CE)

Postdi taurex » 27/09/06 09:58

scusa se mi permetto ma con la mia formula ottieni proprio quello che vuoi tu...
Moderatore di
Immagine
taurex
Utente Senior
 
Post: 145
Iscritto il: 09/08/06 09:34
Località: Asti

Postdi Anthony47 » 27/09/06 13:34

Hai gia' un paio di soluzioni, ottime entrambe.

Volevo comunque dire che in excel non si possono annidare piu' di 7 IF; e' un limite invalicabile.
Il mio suggerimento in questi casi e' di farsi una tabellina con valore minimo / punteggio; del tipo:
A B
0 0
66 1
69 2
72 3
etc
Metti i punteggi in ordine crescente in tabella... Mi pare che tu l' hai fatto in Foglio2 celle A01:A20

Poi per il punteggio invece dei SE usi:
=SE(C30<=0;"";cerca.vert(G30;Foglio2!$A$1:$B$20;2))

I $ sono necessari se vuoi poi copiare la formula in altre celle, e ti mantengono il riferimento alla tabella punteggi; ovviamente invece di A1 e B20 userai i veri indirizzi dove metti la tua tabella punteggi (angolo alto/sx, angolo basso/dx)

Ciao,
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

[Excel] Chiarimenti formula SE

Postdi mariojy » 28/09/06 08:26

Grazie a tutti per i suggerimenti sempre preziosi!!!

Mario.
mariojy
Newbie
 
Post: 7
Iscritto il: 22/09/06 11:51
Località: Marcianise (CE)


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Chiarimenti formula SE":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti