Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Ora e somma differenziata

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Ora e somma differenziata

Postdi gexxy » 19/09/06 00:14

Salve,
2 domande su Excel:

Ho una lista con varie colonne es.
tipo telefonata e durata telefonata
sotto tipo ho urbane interurbane cellulari
sotto durata vi sono le durate delle telefonate
come sommo solo la durata delle telefonate di tipo cellulari visto che sono mescolate tutte insieme?

Quando ottengo la durata la ottengo in secondi...se volessi visualizzarla in minuti come dovrei fare?

Grazie 1000
PIII 866\320 RAM\40Gmaxtor\ASUS CUV4X-E\MATROX-G450 32M\SBLASTER\WIN XP PRO\WINUPDATE FATTO
gexxy
Utente Senior
 
Post: 916
Iscritto il: 07/04/02 02:57

Sponsor
 

Postdi Anthony47 » 19/09/06 01:18

Per sommare tipologie uguali puoi usare una formula matrice:
-se il tipo e' in colonna B e la durata in colonna C, da riga 2 a riga 1000, allora scrivi in F1 "cellulari" (senza virgolette) e in G1 la formula
Codice: Seleziona tutto
=SOMMA((C2:C1000)*(B2:B1000=F1))
che pero' confermerai non con Invia ma con <Contr><Maiusc>Invio (vedrai la formula racchiusa tra parentesi {})
-se cambi la scritta in F1, con altro tipo, cambiera' di conseguenza il conteggio in G1.

Per convertire da secondi (in G1) a minuti, allora in G2 scriverai
Codice: Seleziona tutto
=G1/60


Questo nell' ipotesi che i secondi siano espressi in numeri interi (es 82 secondi) e non in formato "orario" di excel (es. 0.01.22 per indicare 1 minuto e 22 secondi).
In questo secondo caso, se vuoi ottenere i secondi in numeri interi, per la formula in G1 dovrai usare
Codice: Seleziona tutto
=SOMMA((C2:C1000)*(B2:B1000=F1))*86400
(sempre Contr-Maiusc-Invio) oppure *1440 per avere direttamente i minuti.

Per avere direttamente il calcolo di durata per tutte le tipologie di traffico in un unico passo, potresti usare una tabella pivot, usando come layout Riga=tipologia e Colonna "Somma di" Durata

Ciao,
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Ora e somma differenziata":


Chi c’è in linea

Visitano il forum: raimea e 8 ospiti