Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Access] Errore per inserimento immagine.

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Access] Errore per inserimento immagine.

Postdi GEGE » 30/05/06 13:10

Premesso che le mie conoscenze di programmazione in Access sono alquanto limitate, di recente ho rilevato un problema di inserimento di immagini in un campo "OLE" di una tabella.
Io utilizzo Windows 2000 ed Office 2000 oppure Windows XP ed Office xp su due postazioni diverse.
In entrambe i casi quando devo inserire le immagini nel campo "OLE" mi appare una avviso di errore che in sintesi mi avverte che esistono problemi di collegamento con il server OLE che mi impediscono li effettuare l'operazione.
Le immagini sono elaborate sia con Pain Shop Pro 8 che con Microsoft Photo Editor.
Spero esista qualche esperta anima buona che possa darmi una mano.
Grazie in anticipo.
GEGE'

*** Ti ho modificato il titolo la prossima volta racchiudi l'argomento nei Tag[]
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

Sponsor
 

Postdi Alexsandra » 30/05/06 16:18

- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

[Access] Errore per inserimento immagine.

Postdi GEGE » 31/05/06 06:55

Ringrazio Alexsaandra per l'indicazione, ma dal sito indicato ho avuto solo la conferma di come inserire un'immagine in un campo OLE.
Rimane il problema che appare sempre il messaggio di errore sia quando teto di inserire l'immagine nel campo della tabella che nella cornice creata nella maschera di visualizzazione.
Ho provato l'inserimemto sia con l'opzione "CREA DA FILE" che scorrendo l'elenco dei programmi selezionando PSP 8 e MS PHOTO EDITOR.
Non so come fare a riattivare il "Server OLE" come mi vene richiesto.
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

Postdi Alexsandra » 31/05/06 07:22

Anche le mie conoscenze di programmazione in Access sono un pò limitate,mi viene da pensare se hai installato qualche software e fatto qualche Update a qualche programma di difesa
(antivirus o firewall).Potrebbe essere un blocco negli script che ti impedisce di comunicare col server Ole.
Se il messaggio di errore è questo
"Microsoft Access non può comunicare con il server OLE. E’ possibile che il server OLE non sia stato registrato. Reinstallare il server OLE per registrarlo"
Di solito è il Norton che genera questo errore (per caso lo hai installato sul tuo sistema?)
eventualmente posta la descrizione esatta dell'errore che ti viene visualizzato
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

[Access] Errore per inserimento immagine.

Postdi GEGE » 31/05/06 11:32

Come antivirus ho Norton ed il messaggio di errore è esattamente quello evidenziato in risposta.
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

Postdi Alexsandra » 31/05/06 12:29

Allora segui Queste Istruzioni e dovresti risolvere
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

Oggetto: [Access] Errore per inserimento immagine.

Postdi GEGE » 31/05/06 12:42

Grazie per l'aiuto.
Fino alla prossima settimana mi sarà però impossibile provare la soluzione.
Non appena verificato l'esito, lo comunicherò.
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

[Access] Errore per inserimento immagine.

Postdi GEGE » 05/06/06 05:54

Ho disabilitato Norton come indicato dal sito citato, ma i problemi sono rimasti.
Se tento di inserire l'immagine da "Crea da file" mi appare il messaggio "CONNESSIONE CON IL SERVER OLE PERDUTA OPPURE ERRORE DURANTE L'UTILIZZO DEL SERVER OLE. RIAVVIARE IL SERVER OLE E QUINDI RITENTARE L'OPERAZIONE": il problema per me è quello di riavviare il server in quanto anche consultando la Guida in linea non ho trovato indicazioni.
Se seguo la via di aprire direttamente Paint Shop Pro 8 mi appare invece il messaggio: "L'APPLICAZIONE NON E' COLLEGATA AL SERVER OLE. REINSTALLARE L'APPLICAZIONE", cosa che ho fatto ma senza risultato.
Aprendo invece Microsoftt Photo Editor mi viene invece visualizzata una immagine a sfondo bianco quadrata; a questo punto mi tocca aprire l'immagine da inserire e copiarla sull'immagine bianca dopo averne adattato il formato in pixel a quella desiderata: in questo caso l'operazione di inserimento riesce, ma ritengo un poco assurdo dover usare un percorso così lungo e contorto.
Sperando di essermi spiegato in modo comprensibile, auspicherei una soluzione migliore.
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

Postdi Alexsandra » 05/06/06 09:50

Non saprei cosa consigliarti prova a vedere quì http://www.sysadmin.it/pages/guide/guide.asp?ID=31, eventualmente aspetta un consiglio del nostro archimede che è più afferrato in materia.
Ciao
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

[Access] Errore per inserimento immagine.

Postdi GEGE » 05/06/06 12:21

All'idirizzo indicato non sono riuscito a trovare un aiuto.
Grazie comunque per quanto suggerito, mentre aspetto una eventuale risposta da Archimede.
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

Postdi Alexsandra » 05/06/06 15:11

Gli ho mandato un pvt vedrai che quando si collega viene a vedere il topic e saprà consigliarti meglio di mè.
Ciao
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

[Access] Errore per inserimento immagine.

Postdi GEGE » 06/06/06 05:50

Grazie per l'interessamento,
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

Postdi Alexsandra » 06/06/06 07:46

Prego non c'è di che se non ti ha ancora risposto probabile che sia assente per motivi personali. se puoi attendere ancora un pò !!! :D
ciao
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

Re: [Access] Errore per inserimento immagine.

Postdi archimede » 08/06/06 09:57

GEGE ha scritto:Premesso che le mie conoscenze di programmazione in Access sono alquanto limitate, di recente ho rilevato un problema di inserimento di immagini in un campo "OLE" di una tabella.
Non ho molta esperienza nella gestione immagini con Access ma, prima di procedere oltre, sei cosciente del fatto che memorizzare oggetti OLE in un file MDB è una pessima idea?

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

[Access] Errore per inserimento immagine.

Postdi GEGE » 08/06/06 10:14

Con la mia scarsa conoscenza di Access non ho idea delle difficoltà (oppure dell'oppurtunità di inserire oggetti OLE in un file MDB.
Questo inserimento (che fino a qualche tempo fa non mi ha mai creato problemi) mi è necessario per stampare delle tessere di riconoscimento per i membri dell'Associazione di Protezione Civile alla quale appartengo.
La possibilità di stampare dei report con tutti i dati necessari (fototessera compresa) è molto comodo e veloce.
Ho voluto precisarti meglio la mia necessità per giustificare l'inserimento di un'immagine nella banca dati.
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

Postdi archimede » 08/06/06 11:04

Normalmente le immagini vengono lasciate in una cartella sul file system (per evitare che il db si "gonfi" a dismisura) e nella tabella si registra il nome e, eventualmente, il percorso al file fisico.

Vedi qui per ulteriori dettagli.

HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

[Access] Errore per inserimento immagine.

Postdi GEGE » 08/06/06 11:41

Grazie per l'indicazione.
Adesso con calma vedrò di decifrare qualche notizia utile e ti farò sapere.
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58

[Access] Errore per inserimento immagine.

Postdi GEGE » 16/06/06 05:48

Purroppo ho avuto qualche problema e solo ieri ho potuto consultare i riferimenti che mi hai indicato.
Tra le varie cose ho provato anche ad aprire le immagini con "Imaging" per "digitalizzarle" ed a salvarle con altro nome: l'operazione di inserimento mi restituisce gli stessi messaggi e quindi non riesce.
Continuo a non capire come mai fino a qualche tempo fa non avevo avuto problemi e poi di colpo si mè verificato il blocco.
Se possibile attendo qualche altra indicazione. Grazie,
GEGE'
GEGE
Utente Junior
 
Post: 16
Iscritto il: 30/05/06 12:58


Torna a Applicazioni Office Windows


Topic correlati a "[Access] Errore per inserimento immagine.":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti