Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Copiare dati corrispondenti tra 2 fogli

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Copiare dati corrispondenti tra 2 fogli

Postdi Ricky0185 » 17/08/22 10:56

Buongiorno, vorrei trovare una formula (se possibile no VBA) che in questo file per ogni nominativo di Foglio2 mi copi il relativo totale (celle sfondo giallo) su Foglio1 in colonna B nella riga dove su colonna A di Foglio2 c'è lo stesso Nominativo cui si riferisce il totale, tenendo presente che le righe (Articoli) di Foglio2 sono variabili (destinate ad aumentare).
Ringrazio
R
Ricky0185
Utente Senior
 
Post: 135
Iscritto il: 10/12/19 20:38

Sponsor
 

Re: Copiare dati corrispondenti tra 2 fogli

Postdi Anthony47 » 17/08/22 14:19

Probabilmente sarebbe stato molto piu' semplice raccogliere i dati dalla tabella da cui il contenuto di Foglio2 e' stato prelevato; e la tabella di Foglio1 potrebbe essere prodotta direttamente da una tabella pivot.

Rimanendo invece nella situazione che hai presentato:
a) creiamo in Foglio2 una colonna per meglio indicare l'owner di una spesa:
in L3:
Codice: Seleziona tutto
=SE(O(A3<>"";CONTA.VALORI(C2:C1000)=0);A3;L2)

Copia poi verso il basso per la lunghezza stimata del riepilogo

Poi su Foglio1, in B3
Edit: LA FORMULA VA IN B4, NON B3
Codice: Seleziona tutto
=INDICE(Foglio2!$I$1:$I$1000;MAX(SE(Foglio2!$L$1:$L$1000=Foglio1!A4;RIF.RIGA($L$1:$L$1000);"")))

Copia poi verso il basso q.b.
Avatar utente
Anthony47
Moderatore
 
Post: 18453
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Copiare dati corrispondenti tra 2 fogli

Postdi Ricky0185 » 17/08/22 16:08

Non mi funziona. Quando inserisco su Foglio1 in B3 (che debbo scompattare poichè cella unita) la seconda formula mi esce "TotaledaLiquidare" e le celle sottostanti "#VALORE!". Chedevo la formula poichè con la macro
Codice: Seleziona tutto
Sub GestForn()
Dim CL As Range
Dim C As Range
    For Each CL In Sheets("Foglio1").Range("a4:a20")
        If CL.Value = "" Then GoTo 10
    For Each C In Sheets("Foglio2").Range("a3:a30")
        If C.Value = CL.Value Then
   CL.Offset(0, 1).Value = C.Offset(0, 8).End(xlDown).Value
End If
Next 'C
10:
Next
End Sub
se un fornitore non ha movimenti su Foglio2, sul corrispondente rigo di Foglio1 inserisce il valore sottostante crendo duplicati.
Prova a pulire tutti i valori riferiti a Paperino e vedrai su Foglio1 che ha lo stesso valore di Minni.
Quale delle due è più facile da risolvere?
Ciao
Ricky0185
Utente Senior
 
Post: 135
Iscritto il: 10/12/19 20:38

Re: Copiare dati corrispondenti tra 2 fogli

Postdi Anthony47 » 17/08/22 16:51

Nella risposta precedente ho scritto di mettere la seconda formula in B3, ma doveva andare in B4 questo probabilmente ha generato qualche confusione, sorry...

Dopo aver cancellato ad esempio i dati di paperino, ma rispettando il formato, io ottengo questo risultato, che mi sembra giusto
Immagine

Come detto e' piu' semplice importare dalla tabella da cui hai creato Foglio2, se ne pubblichi il formato; o addiritura ottenere la tabella di Foglio1 come tabella pivot da quei dati di origine.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18453
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Copiare dati corrispondenti tra 2 fogli

Postdi Ricky0185 » 17/08/22 18:53

Questo invece è il mio risultato.Misteri della fede o di Excel2003 e XP.
Poi vorrei capire cosa intendi con
importare dalla tabella da cui hai creato Foglio2, se ne pubblichi il formato; o addiritura ottenere la tabella di Foglio1 come tabella pivot da quei dati di origine.
.
Chissà che non risolva.
Ciao
Ricky0185
Utente Senior
 
Post: 135
Iscritto il: 10/12/19 20:38

Re: Copiare dati corrispondenti tra 2 fogli

Postdi Ricky0185 » 17/08/22 21:58

Intanto ho risolto con questa vecchia macro
Codice: Seleziona tutto
Sub EliminaDoppioni()
Application.ScreenUpdating = False
Range("B3:B6").Select
Set currentCell = Worksheets("Foglio1").Range("B3")
Do While Not IsEmpty(currentCell)
Set nextCell = currentCell.Offset(1, 0)
If nextCell.Value = currentCell.Value Then
currentCell.Value = "" '.Interior.ColorIndex = 6
End If
Set currentCell = nextCell
Loop
Range("B4").Select
credo di Ennius, ma con la colonna B molto lunga occorre un sacco di tempo.
Resta sempre valida la precedente richiesta, senza fretta.
Ciao
Ricky0185
Utente Senior
 
Post: 135
Iscritto il: 10/12/19 20:38

Re: Copiare dati corrispondenti tra 2 fogli

Postdi Anthony47 » 18/08/22 08:18

Nella risposta precedente ho scritto di mettere la seconda formula in B3, ma doveva andare in B4 questo probabilmente ha generato qualche confusione, sorry...
...e mi sono anche dimenticato di aggiungere che va messa in forma matriciale, quindi usando Contr-Maiusc-Enter, non sil solo Enter...
Sorry :oops: :D :D
Avatar utente
Anthony47
Moderatore
 
Post: 18453
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Copiare dati corrispondenti tra 2 fogli

Postdi Ricky0185 » 19/08/22 09:12

La seconda formula inserita in B4 in forma matriciale funziona solo se il RIF.RIGA($L$1:$L$1000) è fatto al il Foglio2, oppure metti anche sul foglio1 la prima formula su colonna L.
Ora tutto funziona perciò Risolto.
Buona giornata
R
Ricky0185
Utente Senior
 
Post: 135
Iscritto il: 10/12/19 20:38


Torna a Applicazioni Office Windows


Topic correlati a "Copiare dati corrispondenti tra 2 fogli":


Chi c’è in linea

Visitano il forum: Nessuno e 96 ospiti