Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Report in base a data (filtro tramite formula)

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Report in base a data (filtro tramite formula)

Postdi contiend » 15/01/22 12:47

Ciao a tutti,
sto strutturando un foglio ma non riesco a trovare la soluzione alla tabella che dovrebbe riportarmi i risultati in base alle variabili inserite..

Qui l'esempio
https://docs.google.com/spreadsheets/d/ ... sp=sharing

Nella prima parte (sinistra), è presente una tabella dati. Ogni riga ha un numero progressivo unico (col A).

Nella parte centrale, col K, inserisco i dati che mi interessano.
Nell'esempio ho inserito che voglio vedere i risultati solamente di

- Codice : 2 (col D)
- Data dal 08/05/2020
- Data al 20/12/2021


Nella parte di destra, col N, dovrebbero riportarsi tutti i numeri progressivi unici,
nel range di date indicato e appartenenti al codice da me inserito

Ho indicato il risultato di esempio.
Poi gli altri dati li pesco con un CERCA.VERT

Sapete consigliarmi qualche soluzione?
Grazie
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 172
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: Report in base a data (filtro tramite formula)

Postdi Anthony47 » 16/01/22 09:21

Prova così:
In N5 inserisci la formula
Codice: Seleziona tutto
=SE.ERRORE(PICCOLO(SE(($B$5:$B$200>=$K$6)*($B$5:$B$200<=$K$7)*($D$5:$D$200=$K$9);$A$5:$A$200;"");RIF.RIGA(A1));"")
Da confermare con Contr-Maiusc-Enter, non il solo Enter

Poi le altre colonne le prelevi come adesso, o in blocco con INDICE e CONFRONTA

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18205
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Report in base a data (filtro tramite formula)

Postdi contiend » 22/01/22 14:35

Ciao.
Funziona perfettamente.
Un immenso grazie.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 172
Iscritto il: 20/04/09 17:45


Torna a Applicazioni Office Windows


Topic correlati a "Report in base a data (filtro tramite formula)":

Formula excel
Autore: Nilo69
Forum: Applicazioni Office Windows
Risposte: 16

Chi c’è in linea

Visitano il forum: Nessuno e 29 ospiti