Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel, Funzione CERCA.X

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel, Funzione CERCA.X

Postdi scanacc » 08/01/22 00:53

Ho letto l'interessante topic "Nuove Prestazioni" (viewtopic.php?f=26&t=111058)
Ho cominciato a usare CERCA.X ed è favoloso!

Ho due domande:
se scrivo
Codice: Seleziona tutto
=CERCA.X(I30;$C$30:$C$38;$A$30:$A$38)
mi viene offerto il valore esatto o approssimativo?

Seconda domanda:
Mi sembra di aver capito che scrivere il se.errore(........;"") per evitare errori su cerca.x è superfluo.
Cosa dovrei scrivere al posto di:
Codice: Seleziona tutto
=se.errore(CERCA.X(I30;$C$30:$C$38;$A$30:$A$38);"")
?
Grazie
scanacc
Utente Senior
 
Post: 312
Iscritto il: 06/12/15 10:30

Sponsor
 

Re: Excel, Funzione CERCA.X

Postdi Anthony47 » 09/01/22 14:59

Eppero' prima di chiedere dovresti almeno leggere la sintassi della funzione (il link e' pubblicato nella mia discussione linkata); così vedresti che la funzione dispone (tra l'altro) dei parametri "[modalità_confronto]" e "[se_non_trovato]", ambedue opzionali.
Col primo puoi controllare se cercare un risultato esatto oppure approssimato; col secondo puoi impostare il risultato da riportare nel caso che la ricerca non trovi un valore (e quindi ti consente di evitare l'uso di un Se.Errore addizionale)
La modalita' di confronto di default e' "cerca valore esatto", e questo restituira' la tua prima formula.

Il parametro "[se_non_trovato]" e' il primo dopo "Matrice_Restituita", quindi potresti usare
Codice: Seleziona tutto
=CERCA.X(I30;$C$30:$C$38;$A$30:$A$38;"Non Trovato")


Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18114
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel, Funzione CERCA.X

Postdi scanacc » 09/01/22 16:20

Grazie Anthony!
Si avevo già letto il link di cui parli ma volevo la conferma da te in quanto non sapevo se avevo interpretato bene.
Grazie
scanacc
Utente Senior
 
Post: 312
Iscritto il: 06/12/15 10:30


Torna a Applicazioni Office Windows


Topic correlati a "Excel, Funzione CERCA.X":


Chi c’è in linea

Visitano il forum: Nessuno e 78 ospiti