Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula Concatena Numeri

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula Concatena Numeri

Postdi Francesco6918 » 29/11/21 12:02

Buon giorno amici del forum, ho difficoltà per applicare una formula,  mi spiego:
-ho mille righe (ma ho riportato un piccolo esempio da file) colonna V7: V37 sono cicli; nella colonna X7:X37 ci sono numeri di ricerca. La mia soluzione e' trovare nella colonna  X7:X37 se sono presenti il numero 80 e il numero 81 e concatenarli insieme formando un ambo come esempio lo riportato nella colonna AA7. Forse allegando il file e' più chiaro.

Grazie 

https://we.tl/t-tFRckgDl89
Francesco6918
Utente Senior
 
Post: 240
Iscritto il: 04/03/11 11:20

Sponsor
 

Re: Formula Concatena Numeri

Postdi Anthony47 » 29/11/21 14:15

Non sono certo di aver capito la struttura dei tuoi dati; guardando quello che hai scritto e quello che vedo in colonna AA, prova questa formula da mettere in AA7:
Codice: Seleziona tutto
=SE(E(X7=81;CONTA.SE(SCARTO($X$7;INT((RIF.RIGA($A1)-1)/10)*10;0;9;1);80)>0);"80-81";"")

Da confermare con Contr-Maiusc-Enter, non il solo Enter

Poi copia verso il basso

Fai sapere...
Avatar utente
Anthony47
Moderatore
 
Post: 18453
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Concatena Numeri

Postdi Francesco6918 » 29/11/21 16:21

Ciao Anthony47 ti ringrazio della soluzione funziona benissimo salvo complicazioni ripropongo il problema.

Saluti
Francesco6918
Utente Senior
 
Post: 240
Iscritto il: 04/03/11 11:20

Re: Formula Concatena Numeri

Postdi Francesco6918 » 29/11/21 17:07

Ciao Anthony47 un problema se nella X37 inserisco il numero 81 non mi concatena nulla.

https://we.tl/t-wjLGqc30Vu
Francesco6918
Utente Senior
 
Post: 240
Iscritto il: 04/03/11 11:20

Re: Formula Concatena Numeri

Postdi Anthony47 » 29/11/21 19:21

La formula assume che ci sia regolarita' sulle "serie", mentre l'ultima serie (nell'esempio che hai pubblicato) e' distanziato di 3 righe dal blocco precedente.
Se la mia assunzione non puo' essere garantita (e quindi un blocco deve capitare in qualsiasi posizione, come adesso) allora potremmo usare i dati in colonna V (se hanno sempre l'aspetto come nel file che hai pubblicato) e usare in AA/:
Codice: Seleziona tutto
=SE(E(X7=81;CONTA.SE(SCARTO(X7;1-V7;0;9;1);80)>0);"80-81";"")

Sempre Contr-Maiusc-Enter; poi copiare verso il basso

Fai sapere...
Avatar utente
Anthony47
Moderatore
 
Post: 18453
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Concatena Numeri

Postdi Francesco6918 » 30/11/21 00:11

Ciao Anthony47 che posso dire che al momento funziona benissimo sul file allegato dovrei provare su tutte le righe del file originale comunque a risentirci.

Saluti
Francesco6918
Utente Senior
 
Post: 240
Iscritto il: 04/03/11 11:20

Re: Formula Concatena Numeri

Postdi Francesco6918 » 30/11/21 18:19

Ciao Anthony47 grazie della soluzione funziona

Saluti
Francesco6918
Utente Senior
 
Post: 240
Iscritto il: 04/03/11 11:20


Torna a Applicazioni Office Windows


Topic correlati a "Formula Concatena Numeri":

Formula excel
Autore: Nilo69
Forum: Applicazioni Office Windows
Risposte: 16

Chi c’è in linea

Visitano il forum: Nessuno e 89 ospiti