Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

numerare progressivamente celle piene con condizione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

numerare progressivamente celle piene con condizione

Postdi libraio » 19/08/21 20:30

So Windows 7 + Office 2003

Ciao a tutti,
in un foglio excel con un migliaio di righe piene intervallate da righe vuote vorrei automatizzare la numerazione progressiva delle celle che contengono testo.
Il testo è nelle colonne B e successive; la numerzione dovrebbe essere in colonna A.
Ad intervalli irregolari ci sono righe vuote e le righe piene vengono periodicamente implementate con nuove righe di testo.
Ho trovato la macro seguente, che numera solo le righe piene, saltando quelle vuote:

Public Sub m()
Dim sh As Worksheet
Dim lng As Long
Dim lCont As Long
Set sh = ThisWorkbook.Worksheets("Foglio1")
lCont = 1
With sh
For lng = 2 To 1000
If Len(.Cells(lng, 2).Value) > 0 Then
.Cells(lng, 1).Value = lCont
lCont = lCont + 1
Else
.Cells(lng, 1).Value = ""
End If
Next
End With
Set sh = Nothing
End Sub

ma io vorrei che dopo ogni riga vuota la numerazione ripartisse da 1. E' possibile?...

A titolo di esempio, vorrei ottenere questo risultato:


A2 1 B2 Blu
A3 2 B3 Giallo
A4 3 B4 Rosso
A5 B5 (vuoto)
A6 1 B6 Nero
A7 B7 (vuoto)
A8 1 B8 Viola
A9 2 B9 Azzurro
....

Grazie per l'auto
libraio
Utente Senior
 
Post: 316
Iscritto il: 04/01/10 20:31

Sponsor
 

Re: numerare progressivamente celle piene con condizione

Postdi Anthony47 » 19/08/21 22:16

Via formula non va bene?
In A2 metti la formula
Codice: Seleziona tutto
=SE(B2<>"";A1+1;0)

Formatti A2 in modo da nascondere gli Zero:
-avvia la formattazione; tab Numero, scegli Personalizzato; come tipo scrivi
Codice: Seleziona tutto
0;;;
-completa con Ok

Poi copia A2 verso il basso per le righe che ti serviranno

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17830
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: numerare progressivamente celle piene con condizione

Postdi libraio » 21/08/21 12:35

Grazie Anthony,
è perfetto (e decisamente più veloce della macro...)
libraio
Utente Senior
 
Post: 316
Iscritto il: 04/01/10 20:31


Torna a Applicazioni Office Windows


Topic correlati a "numerare progressivamente celle piene con condizione":


Chi c’è in linea

Visitano il forum: Nessuno e 50 ospiti

cron