Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

funzione VAL.NON.DISP e stampa testo nascosto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

funzione VAL.NON.DISP e stampa testo nascosto

Postdi BG66 » 05/02/21 14:58

Ciao a tutti.
Nel foglio di lavoro "Correttore" ho provato ad usare VAL.NON.DISP e in pratica vorrei che
-> verificasse il nome dell'unità didattica (CELLA A2) e poi confrontasse le risposte del discente (range B5:K5) con
le risposte giuste presenti nella corrispondente riga del range B6:K13
il dato atteso è da riportare nelle corrispondenti celle della riga 3 (check)

Nel foglio di lavoro "Test" ho:
1) bloccato la possibilità di stampare dal programma
2) nascosto i risultati (cella E2) e l'esito (cella E4) con il testo personalizzato (;;;)
ma avrei necessità che quando stampo questi valori siano impressi sulla carta.

https://www.dropbox.com/scl/fi/lcodt0ivfb5m8e9wmxv4o/Test_forum.xlsm?dl=0&rlkey=6cg5iqpxxwztyii9z3ki892h9
Grazie per l'aiuto.
Gene
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 287
Iscritto il: 20/08/16 07:44

Sponsor
 

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi Marius44 » 05/02/21 16:49

Ciao Gene
Mi sembra banale ma prima di stampare modifica la formattazione delle celle e dopo aver stampato la ripristini.
Cioè, modifica la macro così
Codice: Seleziona tutto
Sub Macro3()
  Dim stampa As VbMsgBoxResult
 
  Application.ScreenUpdating = False
  stampa = MsgBox("Vuoi proseguire ?", vbYesNo)
  If stampa = vbNo Then
    MsgBox "Alla prossima"
  Else
    Application.Dialogs(xlDialogPrinterSetup).Show
    Sheets("Test").Select 'ex Sheets(Array("Foglio1", "Foglio2")).Select
    Sheets("Test").Activate
    Range("E2,E4").NumberFormat = "General"         '<----- riga aggiunta
    bStampami = True
    ActiveWindow.SelectedSheets.PrintOut Copies:=1, Collate:=True
    bStampami = False
    Range("E2,E4").NumberFormat = ";;;"             '<----- riga aggiunta
  End If


Ciao,
Mario
Marius44
Utente Senior
 
Post: 573
Iscritto il: 07/09/15 22:00

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi BG66 » 05/02/21 19:41

Ciao Mario,
in realtà avevo il dubbio che sul pc datato che usiamo per la formazione, l'applicazione della modifica rendesse "leggibili" i risultati per un tempo più lungo. Conseguentemente, ho cercato e pensavo di dover ricorrere ad una soluzione più strutturata.

Suggerimenti per la prima domanda?

Grazie.
Gene
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 287
Iscritto il: 20/08/16 07:44

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi Anthony47 » 05/02/21 20:32

Una piccola variante a quanto proposto da Mario:
Su TEST usi E1 come Flag
La formula in E2 la fai diventare
Codice: Seleziona tutto
=SE(E1>0;CONTA.SE(Correttore!B3:K3;"FALSO");"")

Idem inserisci in E4 il test SE(E1>0;etc etc)

E1 e' l'unica cella da formattare ;;;

Poi nella macro metti E1 a 1 a inizio stampa e la riposizioni a 0 a termine:
Codice: Seleziona tutto
  Else
  Range("E1") = 1              '+++++
  Application.Dialogs(xlDialogPrinterSetup).Show
    Sheets("Test").Select 'ex Sheets(Array("Foglio1", "Foglio2")).Select
    Sheets("Test").Activate
    bStampami = True
    ActiveWindow.SelectedSheets.PrintOut Copies:=1, Collate:=True
    bStampami = False
  End If
  Application.ScreenUpdating = True
  Range("E1").ClearContents      '++++
End Sub


Qualsiasi soluzione usi e' meglio se rendi non selezionabili le celle Test - E1:E4

Quanto all'altra questione, se ho capito, potresti usare in Correttore - B3 la formula
Codice: Seleziona tutto
=SE(B5<>"";B5<>SCARTO(B5;CONFRONTA($A$2;$A$6:$A$20;0);0);VERO)

Poi copia verso destra

Ciao a tutti
Avatar utente
Anthony47
Moderatore
 
Post: 18127
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi BG66 » 06/02/21 23:55

Anthony47 ha scritto:Quanto all'altra questione, se ho capito, potresti usare in Correttore - B3 la formula
Codice: Seleziona tutto
=SE(B5<>"";B5<>SCARTO(B5;CONFRONTA($A$2;$A$6:$A$20;0);0);VERO)

Poi copia verso destra
Ciao a tutti


Ciao Anthony.
Ho provato a riportare la formula nel file master (dove le risposte giuste da confrontare sono in foglio specifico "Appoggio") ma mi restituisce un errore da riferimento circolare che non trovo/capisco.
Codice: Seleziona tutto
=SE(B4<>"";B4<>SCARTO(B4;CONFRONTA($A$4;Appoggio!$A$2:$A$26;0);0);VERO)

Mi aiuti a capire dove mi sono perso!!
https://www.dropbox.com/scl/fi/4v4j1yiaotg0vmgazqr3a/Test_forum-V1.xlsm?dl=0&rlkey=gckxux9jbh3zx6giu6e97gsn4

Grazie
Gene
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 287
Iscritto il: 20/08/16 07:44

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi Anthony47 » 07/02/21 01:02

La mia formula precedente va a confrontare la risposta fornita con la riga appropriata della tabelle delle risposte esatte, che prima era nello stesso foglio in cui inserivi la formula; ora invece l'hai spostata nel foglio Appoggio.
Di conseguenza la formula proposta:
=SE(B5<>"";B5<>SCARTO(B5;CONFRONTA($A$2;$A$6:$A$20;0);0);VERO)
ora dovra' far riferimento all'origine della tabella in Appoggio; diventera' quindi (in B5 del foglio Risposte):
Codice: Seleziona tutto
=SE(B4<>"";B4<>SCARTO(Appoggio!B2;CONFRONTA($A$4;Appoggio!$A$2:$A$26;0);0);VERO)


Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18127
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi BG66 » 07/02/21 06:09

Ciao Anthony,
la formula sembra essere "instabile". La prova fatta:

a) Ho modificato(per avere un riscontro immediato) le risposte corrette in APPOGGIO usando sempre la stessa lettera:
Immagine

quindi mi sarei aspettato che tutte le altre lettere fossero dichiarate false e invece:
Immagine

Lo so che basterebbe adattare alle singole righe:
Codice: Seleziona tutto
=SE(B8=Appoggio!B$2;"+";"-")
.
Ma caratterialmente,il non arrivarci mi "infastidisce" di più del raggiungere lo scopo a prescindere.

Quindi se hai voglia di aiutarmi a capire....

PS L'immagine viene "tagliata" prima della risposta 8 ma il senso non cambia.
Per completezza:
Immagine

Grazie
Gene
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 287
Iscritto il: 20/08/16 07:44

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi Anthony47 » 07/02/21 10:51

Le formule fanno sempre perfettamente il loro lavoro; purtroppo nelle modifiche mi sono dimenticato che la base di SCARTO deve essere fissa, cioe' espressa con indirizzo assoluto; quindi:
SCARTO(Appoggio!$B$2;CONFRONTA(
In grassetto gli elementi aggiunti nella formula

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18127
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi BG66 » 07/02/21 17:26

Ciao Anthony,
continua il comportamento anomalo :evil: :
Immagine

Primo dato non corretto è nella colonna G (risposta n°6) e continua " a sbagliare" fino alla decima risposta.
Esempio della formula presente in cella G5 :
Codice: Seleziona tutto
=SE(G4<>"";G4<>SCARTO(Appoggio!$G$2;CONFRONTA($A$4;Appoggio!$A$2:$A$26;0);0);VERO)
.

PS Ho aggiunto anche il testo completo della formula perchè non vorrei farti impazzire per comprendere l'arcano e poi scoprire che ho digitato male qualcosa!!
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 287
Iscritto il: 20/08/16 07:44

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi Anthony47 » 08/02/21 00:54

:oops: :-? :evil:
Evidentemente la mattina prendo degli abbagli piu' forti del solito...
a) Non e' vero che la base di SCARTO deve essere fissa
b) L'origine del problema sta' nel fatto che CONFRONTA (ovviamente) restituisce i risultati a partire da 1, quindi la base di SCARTO (a) deve essere non fissa ma relativa, e soprattutto (b) deve essere posizionato sulla riga 1 e non 2 (o in alternativa avrei dovuto usare "risultato del Confronta -1")

Quindi, in B5 e poi copiare verso destra:
Codice: Seleziona tutto
=SE(B4<>"";B4<>SCARTO(Appoggio!B1;CONFRONTA($A$4;Appoggio!$A$2:$A$26;0);0);VERO)

Che sia la volta buona??
Avatar utente
Anthony47
Moderatore
 
Post: 18127
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi Marius44 » 08/02/21 09:52

Ciao a tutti
@Anthony, utilizzando la tua formula non mi funziona correttamente (la prima A mi dà Falso mentre dovrebbe essere VERO)
Se "aggiusto" la formula come appresso mi sembra che dia il risultato atteso
Codice: Seleziona tutto
=SE(B4="";"";SE(B4=SCARTO(Appoggio!B1;CONFRONTA($A$4;Appoggio!$A$2:$A$26;0);0);VERO;FALSO))


E' corretto?
Ciao,
Mario
Marius44
Utente Senior
 
Post: 573
Iscritto il: 07/09/15 22:00

Re: funzione VAL.NON.DISP e stampa testo nascosto

Postdi Anthony47 » 08/02/21 11:14

Ciao Mario.
Gene non ha mai detto se per la risposta esatta il risultato della formula deve essere VERO o FALSO.
Siccome la sua formula che conta le risposte esatte conta i FALSO io mi sono immaginato che questa (FALSO) e' il risultato che la nuova formula deve dare se la risposta e' corretta; e questo cerca di fare la mia formula.
Quindi aspettiamo Gene...
Buona giornata
Avatar utente
Anthony47
Moderatore
 
Post: 18127
Iscritto il: 21/03/06 16:03
Località: Ivrea

[RISOLTO] funzione VAL.NON.DISP e stampa testo nascosto

Postdi BG66 » 08/02/21 21:48

[RISOLTO]
Ciao a tutti.
Alla fine chi la dura (Anthony), la vince.
In merito al dubbio di Mario, confermo che non era importante la risposta ottenuta ma la correttezza della stessa quindi... dal Rigoletto di Verdi...Questa o quella per me pari sono!!

Grazie mille e alla prossima.

Gene
STAY SAFE
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 287
Iscritto il: 20/08/16 07:44


Torna a Applicazioni Office Windows


Topic correlati a "funzione VAL.NON.DISP e stampa testo nascosto":

Pagine web solo testo
Autore: aggittoriu
Forum: Software Windows
Risposte: 10

Chi c’è in linea

Visitano il forum: raimea e 72 ospiti