Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula SE | cambio formula su eccedenza di un numero

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula SE | cambio formula su eccedenza di un numero

Postdi contiend » 16/01/21 08:25

Ciao a tutti,
sto cercando di strutturare una formula che dica

- controlla il numero nella cella A1

- SE il numero arriva fino a 1650 --> moltiplica "((numero*1,26)*14)/12"

- SE il numero è superiore a 1650
--------> fino a 1650 --------> moltiplica "((numero*1,26)*14)/12"
--------> tutto ciò che è oltre 1650 --------> moltiplica per 1,27


Potete aiutarmi?
Non riesco a dire alla formula di tener conto della formula base
e di aggiungere l'eccedenza con una formula differente.

Grazie dell'aiuto.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: Formula SE | cambio formula su eccedenza di un numero

Postdi Anthony47 » 16/01/21 10:43

Se ho capito, dovrebbe bastare
Codice: Seleziona tutto
=SE(A1<=1650;A1*1,26*14/12;A1*1,27)


Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17445
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula SE | cambio formula su eccedenza di un numero

Postdi contiend » 16/01/21 15:13

Ciao
prima di tutto grazie della risposta.

Quella formula è quella iniziale che avevo pensato
ma a me servirebbe invece una variante che non riesco a ricreare.

Ovvero

Se il numero è sopra i 1650
Poniamo d’esempio 3500

La formula per i primi 1650 di questi 3500
Usa la formula
“ ((1650 *1,26)*14)/12 “

mentre per il restante numero che compone 3500,
Ovvero 1850 (3500-1650),
viene calcolata una formula diversa

(Numero restante)1850*1,27


Il risultato della prima formula basata sui 1650

più il risultato della seconda formula basata sulla differenza che compone 3500, quindi 1850

mi dovrebbe dare il risultato finale.


Se il numero è inferiore a 1650 userà semplicemente la prima formula.

Grazie dell’attenzione e dell’aiuto.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Re: Formula SE | cambio formula su eccedenza di un numero

Postdi Anthony47 » 16/01/21 17:41

Ok, quindi un calcolo "a scaglioni"...

Prova
Codice: Seleziona tutto
=MIN(A1;1650)*1,26*14/12+MAX(0;A1-1650)*1,27

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17445
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula SE | cambio formula su eccedenza di un numero

Postdi contiend » 19/01/21 10:00

Ciao,
perfetto funziona con il ragionamento a scaglioni.
Grazie ancora.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45


Torna a Applicazioni Office Windows


Topic correlati a "Formula SE | cambio formula su eccedenza di un numero":


Chi c’è in linea

Visitano il forum: Marius44, raimea e 30 ospiti