Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

contare specifica parola in una colonna o matrice

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

contare specifica parola in una colonna o matrice

Postdi matzap » 26/10/20 11:16

Ciao, è molto che non ci sentiamo,
Ho un problema da risolvere:
in L31 vorrei contare in una colonna H8:H38, quante volte compare la parola D2.
ad esempio
H9=D2
H10 vuota
H11= D1/D2
H12= D2/C3

Vorrei avere in L31 =3

Potete aiutarmi?
Grazie MIlle!
excel 2010
matzap
Utente Senior
 
Post: 242
Iscritto il: 16/04/13 08:27

Sponsor
 

Re: contare specifica parola in una colonna o matrice

Postdi Anthony47 » 26/10/20 15:56

Bentornato...
Avresti dovuto descrivere piu' chiaramente...
Io l'ho capita così:
In H8:H38 hai dei testi tipo
Codice: Seleziona tutto
Melo
Pero
Melo e pero
Mela
Mela e pera
Melograno

Ora in D2 metti ad es. Melo
Non ho pero' capito se vorresti contare 2 o 3
Nell'ipotesi che sia 2, prova con la formula
Codice: Seleziona tutto
=SOMMA(--(SE.ERRORE(RICERCA($D$2&" ";H8:H18&" ");0)>0))

Se fosse 3:
Codice: Seleziona tutto
=SOMMA(--(SE.ERRORE(RICERCA($D$2;H8:H18&" ");0)>0))

Ambedue le formule vanno confermate con Contr-Maiusc-Enter, non il solo Enter

Se fosse un altro risultato allora dettaglia meglio il tipo di dati e il risultato voluto.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare specifica parola in una colonna o matrice

Postdi matzap » 30/10/20 16:00

Ciao Anthony, in effetti vorrei che contasse 3. Ho provato entrambe le formule mi danno 0
Cosa vuol dire :
Ambedue le formule vanno confermate con Contr-Maiusc-Enter, non il solo Enter
Io ho preso la tua formula e l'ho incollata.
Ciao
excel 2010
matzap
Utente Senior
 
Post: 242
Iscritto il: 16/04/13 08:27

Re: contare specifica parola in una colonna o matrice

Postdi Anthony47 » 30/10/20 20:07

Copia (o scrivi) la formula nella "barra della formula"; poi premi in sequenza i tasti Contr, Maiusc, e infine Enter; poi rilasciali tutti.
In questo modo inserisci una "formula di matrice"; vedi https://support.microsoft.com/it-it/off ... 361075954d
Vedrai la formula inserita tra parentesi graffe ("{}"); ovviamente scrivendo le parentesi graffe da tastiera non ottieni lo stesso risultato.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare specifica parola in una colonna o matrice

Postdi matzap » 03/11/20 16:10

Grazie Anthony! funzionano entrambe.
Grazie soprattutto per il link
a presto
excel 2010
matzap
Utente Senior
 
Post: 242
Iscritto il: 16/04/13 08:27


Torna a Applicazioni Office Windows


Topic correlati a "contare specifica parola in una colonna o matrice":


Chi c’è in linea

Visitano il forum: Nessuno e 22 ospiti