Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Media colonna escludendo determinati valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Media colonna escludendo determinati valori

Postdi contiend » 13/10/20 16:20

Ciao a tutti,
vi chiedo aiuto perchè non saprei come agire.

Ho una colonna di persone, alla quale corrispondono determinati dati.
Ho poi creato una formula base per effettuare la media di questi valori.

A questo punto ho un problema. Vorrei escludere da questa formula di media,
alcuni soggetti. Soggetti variabili.

Per questo ho indicato con una X a fianco queste persone.

Nel momento che inserisco la X vorrei che i numeri non fossero contanti nella media.
E' possibile con una formula?


allego un documento d'esempio.
https://docs.google.com/spreadsheets/d/ ... sp=sharing


La formula andrebbe in C2
tenendo conto delle X presenti in A4 : A21
escludendo così i dati presenti nella colonna C

Ringrazio dell'attenzione
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 159
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: Media colonna escludendo determinati valori

Postdi Anthony47 » 13/10/20 20:24

Ad esempio:
Codice: Seleziona tutto
=MEDIA(SE(A4:A21="x";"";C4:C21))

Anzi, XL2010 gia' dispone della funzione MEDIA.SE, quindi potresti usare piu' semplicemente
Codice: Seleziona tutto
=MEDIA.SE(A4:A21;"<>x";C4:C21)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media colonna escludendo determinati valori

Postdi contiend » 14/10/20 13:10

MEDIA.Se ha funzionato perfettamente.

Grazie mille.
Come sempre indispensabili :D
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 159
Iscritto il: 20/04/09 17:45


Torna a Applicazioni Office Windows


Topic correlati a "Media colonna escludendo determinati valori":

Valori
Autore: losito84
Forum: Applicazioni Office Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti