Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel cerca vert data recente

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel cerca vert data recente

Postdi saxas » 12/10/20 16:01

Salve a tutti
Ho 2 tabelle su 2 fogli
in una tabella ho gli interventi effettuati
B C G
Nome Data Codice

in una tabella sul secondo foglio
D J
Nome Codice

Nella Colonna "J" del secondo foglio dovrei con un cerca.vert o altra funzione trovare il codice della colonna "G" del primo foglio che abbia lo stesso nome ma con la data più recente

ho provato inserendo nella colonna "J" la seguente funzione matriciale ma mi da errore o cmq non mi dà ciò che desideravo
Codice: Seleziona tutto
=MAX(SE(Interventi!B$1:B$880=D14;Interventi!C$1:C$880))


come posso risolvere?
Win10 - Office 2016 Ita
saxas
Utente Junior
 
Post: 55
Iscritto il: 14/11/13 16:58

Sponsor
 

Re: Excel cerca vert data recente

Postdi Anthony47 » 12/10/20 18:27

Mi voglio semplificare la vita, quindi parto con l'ipotesi che l'elenco sia in ordine di date crescxenti. In questo caso potresti usare:
Codice: Seleziona tutto
=INDICE(Interventi!$G$1:$G$800;MAX(SE(Interventi!$B$1:$B$800=D14;RIF.RIGA($B$1:$B$800);"")))


Fai sapere...
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel cerca vert data recente

Postdi saxas » 12/10/20 19:24

purtroppo non funziona, mi da il valore della prima riga,
non vedo il riferimento alla colonna della data nel foglio interventi , colonna C
ho cercato di fare qualche modifica, ma mi da risultati diversi da quelli occorrenti

Mi voglio semplificare la vita, quindi parto con l'ipotesi che l'elenco sia in ordine di date crescxenti. In questo caso potresti usare:

si li ho inseriti in ordine crescente (anche se non posso dare per scontato che in futuro ci possa essere qualche cambiamento)
Win10 - Office 2016 Ita
saxas
Utente Junior
 
Post: 55
Iscritto il: 14/11/13 16:58

Re: Excel cerca vert data recente

Postdi saxas » 12/10/20 20:02

Allego file di esempio

http://www.filedropper.com/provapcfacile_6

in pratica nel foglio "report" mi dovrebbero apparire i numeri evidenziati in giallo
Win10 - Office 2016 Ita
saxas
Utente Junior
 
Post: 55
Iscritto il: 14/11/13 16:58

Re: Excel cerca vert data recente

Postdi Anthony47 » 12/10/20 21:44

Ho dimenticato di dire che la formula va inserita nella barra della formula e confermata con la combinazione Contr-Maiusc-Enter. Poi va copiata verso il basso

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel cerca vert data recente

Postdi saxas » 12/10/20 21:52

avevo provato pure, ma boh..
ADESSO FUNZIONA
se hai tempo potresti spiegare perchè e come, nonostante abbia letto e riletto le proprietà delle funzioni, non riesco a capirla, anche perchè non fa riferimento alla data, bensì all'ultimo dato inserito,
e se dovessi avere delle date alla rinfusa, senza un ordine?
Win10 - Office 2016 Ita
saxas
Utente Junior
 
Post: 55
Iscritto il: 14/11/13 16:58

Re: Excel cerca vert data recente

Postdi Anthony47 » 13/10/20 00:14

La formula funziona bene solo se le date sono in ordine crescente; in questo caso infatti basta cercare l'ultima riga su cui compare il "numero" (fatto tramite la parte MAX(SE(Interventi!$B$1:$B$800=D2;RIF.RIGA($B$1:$B$800);""))), con cui INDICE ci restituisce il "codice"

Se le date non sono in ordine allora bisogna fare un ulteriore passaggio e la formula potrebbe essere:
Codice: Seleziona tutto
=INDICE(Interventi!$G$2:$G$800;CONFRONTA(D2&MAX(SE(Interventi!$B$2:$B$800=D2;Interventi!$C$2:$C$800;""));Interventi!$B$2:$B$800&Interventi!$C$2:$C$800;0))
Sempre Contr-Maiusc-Enter

Cioe' (partendo dalla parte interna della formula) si cerca la data maggiore di un certo numero (vedi MAX+SE), si cerca la posizione di "numero"&DataMaggiore (vedi CONFRONTA) e la si usa tramite INDICE per ottenere il "codice"

Semplice :D ; o no :-? ?
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel cerca vert data recente

Postdi saxas » 13/10/20 06:11

Grazie,
Funziona benissimo.
Win10 - Office 2016 Ita
saxas
Utente Junior
 
Post: 55
Iscritto il: 14/11/13 16:58


Torna a Applicazioni Office Windows


Topic correlati a "Excel cerca vert data recente":


Chi c’è in linea

Visitano il forum: Nessuno e 29 ospiti

cron