Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Ricerca all'iterno di una cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Ricerca all'iterno di una cella

Postdi scanacc » 02/10/20 14:29

Buongiorno, sono alla ricerca di una formula che praticamente dovrebbe fare questo lavoro.
1) Guardare cosa c'è scritto nella cella c3 (dove ci sono scritte un sacco di cose del tipo "Devi dire a Tizio di prendere il cane" oppure "Ricordarsi di pagare i lavori per il tetto del capannone" etc etc).
2) Se tra tutte le cose che ci sono scritte, vedi che c'è scritto MARIO ROSSI, scrivi VERO, altrimenti scrivi FALSO

Chi mi aiuta che sono già 2 ore che ci sbatto la testa?

*Vero e Falso nel senso di far girare un comando
scanacc
Utente Senior
 
Post: 282
Iscritto il: 06/12/15 10:30

Sponsor
 

Re: Ricerca all'iterno di una cella

Postdi Anthony47 » 02/10/20 15:06

Probabilmente
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("MARIO ROSSI";C3));FALSO;VERO)

Sostituisci "Vero" con quello che tu intendi per "far girare un comando"

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Ricerca all'iterno di una cella

Postdi scanacc » 02/10/20 15:44

Grazie! Che vuol dire se(val.errore?
scanacc
Utente Senior
 
Post: 282
Iscritto il: 06/12/15 10:30

Re: Ricerca all'iterno di una cella

Postdi Anthony47 » 02/10/20 16:39

Codice: Seleziona tutto
Grazie! Che vuol dire se(val.errore?

Che domanda e'??

SE e VAL.ERRORE sono due funzioni native di Excel

Sintassi (dall'help di Excel)
SE(Test;Risultato se Test=Vero;Risultato se Test=Falso)


VAL.ERRORE(Argomento)
Restituisce Vero se Argomento = un Errore; oppure restituisce Falso

Aggiungo due righe su TROVA:
TROVA(Testo da Cercare;Stringa in cui cercare[;Opzionale: A partire da quale crt])
Restituisce la posizione in cui trova "Testo da Cercare", oppure l'errore #VALORE se il testo non viene trovato

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Ricerca all'iterno di una cella

Postdi scanacc » 03/10/20 16:53

ma si può unire con la funzione Or?
sto provando da un po e non ci sto riuscendo mannaggia

=SE(o(VAL.ERRORE(TROVA("MARIO ROSSI";C4);VAL.ERRORE(TROVA("MASSIMO VERDI";C4));FALSO;VERO)
Mi da errore
Dove sbaglio?
scanacc
Utente Senior
 
Post: 282
Iscritto il: 06/12/15 10:30

Re: Ricerca all'iterno di una cella

Postdi Anthony47 » 03/10/20 19:02

Cosi' come l'hai scritta le parentesi non quadrano
Cosi' e' formalmente corretta:
Codice: Seleziona tutto
=SE(O(VAL.ERRORE(TROVA("MARIO ROSSI";C4));VAL.ERRORE(TROVA("MASSIMO VERDI";C4)));FALSO;VERO)

(noterai la parentesi chiusa aggiuntiva prima del "FALSO;VERO" finale)

In quel modo la formula restituira' VERO solo se trova sia "MARIO ROSSI" che "MASSIMO VERDI" nella stessa cella C4

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Ricerca all'iterno di una cella

Postdi scanacc » 04/10/20 23:03

... ma posso invece avere VERO se TROVA anche solo 1 di queste elementi di ricerca (MARIO ROSSI o MASSIMO VERDI)?
Se non lo posso fare con TROVA, con cosa lo potrei fare?
scanacc
Utente Senior
 
Post: 282
Iscritto il: 06/12/15 10:30

Re: Ricerca all'iterno di una cella

Postdi Anthony47 » 05/10/20 11:57

Allora non O, ma E:
Codice: Seleziona tutto
=SE(E(VAL.ERRORE(TROVA("MARIO ROSSI";C4));VAL.ERRORE(TROVA("MASSIMO VERDI";C4)));FALSO;VERO)
Avatar utente
Anthony47
Moderatore
 
Post: 17219
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Ricerca all'iterno di una cella":


Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti