Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

errore 19/01/1900 e #Valore

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

errore 19/01/1900 e #Valore

Postdi alfroning » 19/09/20 17:21

Buonasera a tutti,

Ho predisposto un file di riepilogo di alcuni dati, ma impostando la formula alla prima cella e tirando giù il cursore, quando incontra celle vuote mi restituisce "01/01/1900 o #Valore, come si ovviare, ogni suggerimento sarà gradito.

Grazie in anticipo.

Si tratta del secondo foglio che pesca nel primo, del file allegato:

http://www.filedropper.com/test_26171
alfroning
Utente Junior
 
Post: 27
Iscritto il: 31/07/20 16:19

Sponsor
 

Re: errore 19/01/1900 e #Valore

Postdi Anthony47 » 19/09/20 19:23

In Excel, 0 corrisponde (se considerata una Data) al 0/genn/1900 e 1 al 1/genn/1900
Quindi se formatti come data un valore pari a Zero visualizzerai 0/gen/1900 (nel formato prescelto)
Se vuoi evitare questa possibilita' allora usa nella formula la notazione SE(Cella>0;Cella;"")

Quale e' la formula di cui parli?

Nella tua tabella ci sono molte formule del tipo =SE(VAL.NON.DISP(FORMULA1;0;FORMULA1))
Esempio:
Codice: Seleziona tutto
=SE(VAL.NON.DISP(SE(A2="chiusa ";" ";CERCA.VERT(A2;'Procedure di gara 2020'!$B$4:$H$100;4;FALSO)));0;SE(A2="chiusa ";" ";CERCA.VERT(A2;'Procedure di gara 2020'!$B$4:$H$100;4;FALSO)))


Ricorda che puoi semplificare la formula usando la funzione Se.Errore:
Codice: Seleziona tutto
=SE.ERRORE(LaFormula;IlValoreSeLaFormulaRestituisceErrore)


Quindi la suddetta formula diventerebbe:
Codice: Seleziona tutto
=SE.ERRORE(SE(A2="chiusa ";" ";CERCA.VERT(A2;'Procedure di gara 2020'!$B$4:$H$100;4;FALSO));0)


E se e' quella la formula di cui parli, con la modifica che ho suggerito sarebbe:
Codice: Seleziona tutto
=SE.ERRORE(SE(A2="chiusa ";" ";SE(CERCA.VERT(A2;'Procedure di gara 2020'!$B$4:$H$100;4;FALSO)>0;CERCA.VERT(A2;'Procedure di gara 2020'!$B$4:$H$100;4;FALSO);""));"")


Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17155
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "errore 19/01/1900 e #Valore":


Chi c’è in linea

Visitano il forum: Nessuno e 22 ospiti