Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] conta con condizioni su più colonne

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] conta con condizioni su più colonne

Postdi karug64 » 08/02/20 16:32

Salve a tutti.

Ho un foglio così composto:

Immagine

avrei bisogno di avere in una cella una formula col conteggio delle volte in cui Andrea è OUT nell'intervallo (nell'esempio = 4)

Potreste aiutarmi ?
Grazie
Office 2010
karug64
Utente Senior
 
Post: 706
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: [Excel] conta con condizioni su più colonne

Postdi Anthony47 » 08/02/20 19:37

Probabilmente:
Codice: Seleziona tutto
=CONTA.PIÙ.SE(D1:D100;"andrea";A1:A100;"out")


Edit
Correggo:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A1:A100="out");(D1:D100="andrea")+(E1:E100="andrea")+(F1:F100="andrea")+(G1:G100="andrea"))

Perche' immagino che bisogna guardare non la sola colonna D ma anche le E-F-G

Ho supposto che non sia possibile che lo stesso nominativo compaia in piu' colonne nella stessa riga; e se compare si conta 1 sola volta
Avatar utente
Anthony47
Moderatore
 
Post: 16790
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] conta con condizioni su più colonne

Postdi karug64 » 09/02/20 20:10

Anthony47 ha scritto:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A1:A100="out");(D1:D100="andrea")+(E1:E100="andrea")+(F1:F100="andrea")+(G1:G100="andrea"))

Perche' immagino che bisogna guardare non la sola colonna D ma anche le E-F-G

Ho supposto che non sia possibile che lo stesso nominativo compaia in piu' colonne nella stessa riga; e se compare si conta 1 sola volta


Supposizioni corrette, soluzione perfetta !!

Grazie
Office 2010
karug64
Utente Senior
 
Post: 706
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] conta con condizioni su più colonne":

Dimensioni celle excel
Autore: nippon
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 23 ospiti