Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel 2010 sbaglia i calcoli

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel 2010 sbaglia i calcoli

Postdi dipdip » 18/12/19 01:10

Ciao a tutti,

mi sono accorto poco fa che una cella di Excel 2010 che avrebbe dovuto restituire un valore 0, mi dava invece un valore -0 (simbolo negativo davanti alla cifra). Ho allora incrementato i decimali sino a 30 cifre e con mia somma sorpresa ho notato che il calcolo era effettivamente errato.

Ho copiato gli stessi valori in un foglio nuovo e di nuovo stesso risultato errato!

Il calcolo semplicissimo é
cella A1 valore 51,01
cella A2 valore -50
cella A3 valore -1.01
cella A4 formula =somma(A1:A3) che restituisce il valore -0,0000000000000019984014443252800000

Se in cella A1 cambio il valore in 41,01, allora la somma restituisce esattamente 10.

Ho effettuato svariate prove, cambiando sia interi che decimali: con questi ultimi sembra più facile errare ma non trovo una discriminante.

Qualcuno ne sa qualcosa? Capita anche a voi?

Grazie.

dipdip
dipdip
Utente Junior
 
Post: 67
Iscritto il: 26/02/14 14:43

Sponsor
 

Re: Excel 2010 sbaglia i calcoli

Postdi Anthony47 » 18/12/19 01:27

Excel fa i calcoli usando una precisione su 15 digit; nel tuo caso, visto che partiamo da numeri con 2 digit la precisione e' quindi su 17 cifre.
Con molto meno l'uomo e' arrivato fino alla Luna, quindi non dovrebbero essere errori da mettere in ginocchio la media contabilita'.

Per evitare questi effetti, nelle formule finali inserisci un arrotondamento, tipo
Codice: Seleziona tutto
=ARROTONDA(SOMMA(A1:A3);6)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16744
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel 2010 sbaglia i calcoli

Postdi dipdip » 18/12/19 09:21

Ciao Anthony,

non sapevo di questo limite a 15 digit, conosco ed utilizzo la funzione ARROTONDA ma era giusto per capire se si tratta di un problema solo mio o generale di Excel.

Il punto è che ora dovrò rivedere tutti i miei calcoli per la spedizione su Marte... :lol: :lol: :lol: ;)

Buona giornata!

dipdip
dipdip
Utente Junior
 
Post: 67
Iscritto il: 26/02/14 14:43

Re: Excel 2010 sbaglia i calcoli

Postdi Anthony47 » 20/12/19 01:41

Per "prestazioni e limiti" di EXcel: https://support.office.com/it-it/articl ... 9d656771c3
Avatar utente
Anthony47
Moderatore
 
Post: 16744
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel 2010 sbaglia i calcoli":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti