Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerca.vert che parte dal basso

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca.vert che parte dal basso

Postdi marcoc » 09/09/19 20:35

ciao a tutti,
esiste una formula simile al cerca.vert che riporti l'ultimo valore in elenco? intendo, che anziché partire a cercare dalla prima riga in altro, parta dalla prima in basso?
Avatar utente
marcoc
Utente Senior
 
Post: 262
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: cerca.vert che parte dal basso

Postdi Anthony47 » 10/09/19 01:57

Cerca.Vert ha le sue regole, e la ricerca di valori esatti riguarda solo il primo elemento che viene trovato in tabella; la ricerca di valori "approssimati" presuppone che la colonna di ricerca debba avere i valori disposti in ordine crescente, e in caso di doppioni non e' garantito quale dei doppioni sara' rilevato.
Insomma "oggi" non ne esci se non con una formula piu' complessa. Vediamo...

Ipotizziamo di avere una tabella come questa:
Immagine

In F2 e' presente la classica formula
Codice: Seleziona tutto
=CERCA.VERT(E2;A2:C11;3;0)
Cercando CP5 verra' quindi trovato il dato in riga 2 e restituito il valore 1,36

In G2 e' usato Indice /Confronta:
Codice: Seleziona tutto
=INDICE(C2:C11;CONFRONTA(E2;A2:A11;0))
Il risultato e' lo stesso: Confronta rileva il primo CP5 in riga 2 e Indice restituisce 1,36

In F4 e' invece usata una formula in grado di restituire l'ultimo valore presente in tabella; la formula usata:
Codice: Seleziona tutto
=INDICE(C1:C11;MAX(SE(E2=A2:A11;RIF.RIGA(A2:A11);"")))
Da confermare con Contr-Maiusc-Enter, non il solo Enter

La seconda parte della formula restituisce l'ultima riga su cui viene trovato il valore cercato (E2=CP5); la funzione Indice restituisce quella riga della colonna C

Capito il concetto adatterai la formula ai tuoi dati.

C'e' pero' una buona notizia: e' in arrivo la nuova funzione CERCA.X (XLOOKUP, in Inglese), che tra le opzioni contiene anche "cerca dal basso"; e' l'evoluzione di Cerca.Vert e Cerca.Orizz
La notizia cattiva e' che sara' rilasciata solo agli utenti che usano Office 365 in abbonamento; dovrebbe arrivare con gli aggiornamenti di Settembre o Ottobre

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16574
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerca.vert che parte dal basso

Postdi zsadist » 10/09/19 14:18

Ciao
inoltre, sarebbe comodo avere una tua tabella di esempio, in quanto, se trattasi di valori numerici e con più criteri di ricerca (colonne e o righe), puoi usare il CONTA.PIU.SE o SOMMA.PIU.SE, a secondo di quello che ti serve..

utilizzando insieme anche, se necessario, il MAX.PIU.SE o il MIN.PIU.SE.....

insomma, con gli strumenti di oggi, si può ovviare al classico CERCA.VERT
Adattati! L'incapacità di cambiare direzione porta alla sconfitta
zsadist
Utente Junior
 
Post: 76
Iscritto il: 04/04/19 13:48

Re: cerca.vert che parte dal basso

Postdi marcoc » 11/09/19 10:43

ottimo!
grazie!
Avatar utente
marcoc
Utente Senior
 
Post: 262
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "cerca.vert che parte dal basso":


Chi c’è in linea

Visitano il forum: Nessuno e 27 ospiti