Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Esclusione Punti Da Una Tabella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Esclusione Punti Da Una Tabella

Postdi Francesco6918 » 21/01/19 17:17

Buonasera a tutti vorrei modificare una formula ma non riesco forse il problema e' molto più grosso per le mie capacità con excel, vado alla descrizione del problema vorrei escludere alcuni punti da una tabella, nella colonna S7:S10 ho riportato I nomi, nella tabella T7:AC11 ci sono i punteggi corrispondenti 'ai nomi, nella cella AF4 selezionando un nome con questa formula che grazie a Anthony47 : formula
Codice: Seleziona tutto
=SE.ERRORE(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);PICCOLO(SE(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>"";RIF.COLONNA($T$1:$AC$1)-RIF.COLONNA($T$1)+1;"");RIF.COLONNA(A1)));"")
inserendola in AH4 e trascinata fino a AK4 riesco a riportare tutti i punteggi in corrispondenza a un nome fin qui ci siamo, vorrei modificarla invece di riportare tutti i punteggi relativi a nomi ma escludendone alcuni tipo quei punteggi inseriti nelle due celle AM4 e AN4 (COME DA ESEMPIO RIPORTATO NEL FILE) come risultato da ottenere riportato nelle due celle AP4 e AQ4, con il file e' molto più chiaro, spero.

GRAZIE

http://www.filedropper.com/esclusionepunti
Francesco6918
Utente Senior
 
Post: 211
Iscritto il: 04/03/11 11:20

Sponsor
 

Re: Esclusione Punti Da Una Tabella

Postdi Anthony47 » 21/01/19 23:25

Devi lavorare sul SE che individua quali valori prendere e quali no; ora e'
SE(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>"";SeVero;SeFalso)

Deve diventare SE((INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>"")*(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>$AM$4)*(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>$AN$4);SeVero;SeFalso)

Insomma la formula in AH4 va modificata in
Codice: Seleziona tutto
=SE.ERRORE(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);PICCOLO(SE((INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>"")*(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>$AM$4)*(INDICE($T$7:$AC$11;CONFRONTA($AF4;$S$7:$S$11;0);0)<>$AN$4);RIF.COLONNA($T$1:$AC$1)-RIF.COLONNA($T$1)+1;"");RIF.COLONNA(A1)));"")

Poi la copi verso destra

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17446
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Esclusione Punti Da Una Tabella

Postdi Francesco6918 » 22/01/19 10:50

Grazie Anthony47 funziona benissimo.

Saluti
Francesco6918
Utente Senior
 
Post: 211
Iscritto il: 04/03/11 11:20

Re: Esclusione Punti Da Una Tabella

Postdi Francesco6918 » 25/01/19 12:54

Buongiorno ciao Anthony47 vorrei porre un quesito la formula al contrario, mettiamo il caso che conosco il riferimento o la posizione del punteggio in questo caso il numero 3 della cella AI4 corrisponde al nome Nicola punteggio 66, mentre il numero 9 cella AJ4 corrisponde nome sempre Nicola punteggio 12,quale formula dovrei applicare, allego il file per essere più chiari .

Grazie

http://www.filedropper.com/riferimentopunti
Francesco6918
Utente Senior
 
Post: 211
Iscritto il: 04/03/11 11:20

Re: Esclusione Punti Da Una Tabella

Postdi Anthony47 » 26/01/19 02:10

Perdona, mi sento come il vigile di piazza del Duomo nella scena con Toto' e Peppino...

Questi sono i tuoi dati: Immagine
(per vedere l'immagina completa: Tasto Dx sull'immagine, scegli Visualizza immagine)

Vuoi, noto il nominativo (Nicola) e l'intestazione di colonna (3 e 9) ottenere i valori 66 e 12?
Se Si, allora, in AI5 metti la formula
Codice: Seleziona tutto
=SE.ERRORE(INDICE($S$7:$AC$20;CONFRONTA($AF4;$S$7:$S$20;0);CONFRONTA(AI$4;$S$5:$AC$5;0));"")

Poi copi verso destra

Se invece "No" allora spiega bene l'obiettivo da raggiungere.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17446
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Esclusione Punti Da Una Tabella

Postdi Francesco6918 » 26/01/19 13:16

Grazie Anthony47 va benissimo

Saluti
Francesco6918
Utente Senior
 
Post: 211
Iscritto il: 04/03/11 11:20


Torna a Applicazioni Office Windows


Topic correlati a "Esclusione Punti Da Una Tabella":


Chi c’è in linea

Visitano il forum: Nessuno e 31 ospiti