Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Risultati traslati con formula indice

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Risultati traslati con formula indice

Postdi BG66 » 20/01/19 10:18

Ciao a tutti,
nelle colonne E - F - G del foglio D_day, vorrei riportare i valori presenti nel foglio DB tenendo conto del giorno e del turno.
Ho usato:
Codice: Seleziona tutto
=INDICE(DB!$D$2:$D$1096;CONFRONTA(D_day!$D$3;DB!$B$2:$B$1096);CONFRONTA(D_day!D7;DB!$C$2:$C$1096;0))

ma ottengo risultati diversi da quelli attesi.

Dove sbaglio?

https://www.dropbox.com/s/1n0iltrajgkc98c/2_SCARTI_2019_vForum2.xlsm?dl=0
Grazie per l'aiuto
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 193
Iscritto il: 20/08/16 07:44

Sponsor
 

Re: Risultati traslati con formula indice

Postdi cromagno » 20/01/19 11:31

Ciao,
c'è più di un errore in quella formula:
manca lo zero come ultimo argomento della funzione CONFRONTA e... pur considerando un range di una sola colonna come primo argomento della funzione INDICE, utilizzi due funzioni CONFRONTA per trovare sia il numero di riga che quello di colonna; basta trovare la riga ed usare in modo appropriato i simboli dollaro ($) per i riferimenti di range/cella.

In cella E7 (da copiare poi a destra ed in basso):
=INDICE(DB!D$2:D$1096;CONFRONTA($D$3;DB!$B$2:$B$1096;0)+RESTO(RIF.RIGA(A1)-1;3))

Ciao
Tore
Windows 10 + Office 2016 (ita)
"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Avatar utente
cromagno
Utente Junior
 
Post: 60
Iscritto il: 08/10/16 16:33
Località: Sardegna

Re: Risultati traslati con formula indice

Postdi BG66 » 20/01/19 14:45

[RISOLTO]
Ciao Tore,
grazie mille.
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 193
Iscritto il: 20/08/16 07:44

Re: Risultati traslati con formula indice

Postdi Anthony47 » 20/01/19 18:55

Una possibile alternativa alla formula di Tore:
In E7
Codice: Seleziona tutto
=PICCOLO(SE($D$3&$D7=DB!$B$1:$B$2000&DB!$C$1:$C$2000;DB!D$1:D$2000;"");1)
Da confermare con Contr-Maiusc-Enter, poi copiare nelle altre celle interessate

Trattandosi di una formula "a matrice" essa ha senso solo se nel foglio DB non e' garantita la presenza ciclica, per ogni data, delle informazioni 1°turno /2°turno /3°turno

Ciao a tutti
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16511
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Risultati traslati con formula indice":


Chi c’è in linea

Visitano il forum: Nessuno e 28 ospiti