Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Ciao a tutti sono un nuovo iscritto ed ho un problema.

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Ciao a tutti sono un nuovo iscritto ed ho un problema.

Postdi iogonny » 16/04/18 20:12

Ho una tabella Excel con la colonna A formata da celle con contenuto diverso , es: A1 ROSSO A2 NERO ROSSO A3 BIANCO NERO ecc.
Devo inserire una formula a colonna E con queste condizioni:
se A1 è = ROSSO, NERO ROSSO, BIANCO NERO oppure RO, NE, BIANCO ( quindi anche una parte della parola) deve copiarmi il valore indicato in colonna D1, ALTRIMENTI 0.
Grazie a tutti quelli che possono aiutarmi.
iogonny
Newbie
 
Post: 3
Iscritto il: 16/04/18 19:58

Sponsor
 

Re: Ciao a tutti sono un nuovo iscritto ed ho un problema.

Postdi Anthony47 » 17/04/18 02:08

Ciao a tutti sono un nuovo iscritto ed ho un problema
Eh he, mai nessuno che si iscrive solo per salutarci :D

Ho cercato di capire la domanda ma ho rischiato di fondere il neurone di sinistra :-? , quindi ho desistito.

Allora, assodato che in colonna A hai una sequenza di parole, e che cerchi una formula da mettere in colonna E, non ho capito con quale entita' il contenuto di A va confrontato per determinare se il risultato va preso da D o deve essere 0.

Puoi provare a ridescrivere la richiesta, alla luce di questo dubbio? Magari allegando anche solo una immagine dei tuoi dati.
Per le istruzioni su come allegare una immagine:
viewtopic.php?f=26&t=103893&p=605488#p605488

Ciao, ti aspettiamo...
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16511
Iscritto il: 21/03/06 16:03
Località: Ivrea

Problema su una formula

Postdi iogonny » 17/04/18 17:10

https://s20.postimg.cc/5faf6nyhp/Excel_formul.jpg
Ho una tabella excel (vedi link) dove nella colonna evidenziata in giallo ho delle celle che contengono TESTO con una o più parole separate da spazi es(ROSSO NERO). La formula semplice (=se(E3="ROSSO NERO";F3;0) è chiaro che funziona perchè ho inserito il testo completo ma io ho la necessità che funzioni anche se nella mia formula inserissi "ROS", oppure solo "NERO". Praticamente anche solo una parte di quanto contenuto nella cella.
Spero di essermi espresso in modo comprensibile così Antony non mi tira gli orecchi un'altra volta.
Saluti e grazie per la risposta.
Iogonny
iogonny
Newbie
 
Post: 3
Iscritto il: 16/04/18 19:58

Re: Ciao a tutti sono un nuovo iscritto ed ho un problema.

Postdi Anthony47 » 17/04/18 18:15

Con i nuovi riferimenti suggerisco di provare con
Codice: Seleziona tutto
=SE(SE.ERRORE(TROVA(MAIUSC(E3);"ROSSO NERO");0)>0;F3;0)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16511
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Ciao a tutti sono un nuovo iscritto ed ho un problema.

Postdi iogonny » 17/04/18 23:04

=SE(SE.ERRORE(TROVA(MAIUSC(E3);"ROSSO");0)>0;0;F3)
LA FORMULA FUNZIONA SE INVERTO LA PARTE FINALE 0;F3 con F3;0 in questo caso mi inserisce il valore che trova in F3.
ORA HO LA NECESSITA' DI INSERIRE NUOVE CONDIZIONI ( anzichè solo ROSSO dovrei inserire altre parole tipo CONTO, SPESE ecc ma come faccio ad allungare la formula ? dovrei usare OR ? o è sufficiente intervenire all'interno della formula stessa inserendo le nuove parole ?
Saluti
Iogonny
iogonny
Newbie
 
Post: 3
Iscritto il: 16/04/18 19:58

Re: Ciao a tutti sono un nuovo iscritto ed ho un problema.

Postdi Anthony47 » 18/04/18 12:22

Devi spiegare il problema nella sua intierezza, cosi' facciamo il lavoro giusto una sola volta.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16511
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Ciao a tutti sono un nuovo iscritto ed ho un problema.":

Salve Tutti
Autore: caracasve
Forum: Forum off-topic
Risposte: 1
Nuovo PC e VM
Autore: Rolas
Forum: Assistenza Hardware
Risposte: 15

Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti