Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - numerazione progressiva al cambio di anno

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - numerazione progressiva al cambio di anno

Postdi giostacchio » 11/01/18 09:32

come da titolo è possibile realizzare un elenco di numeri progressivi che si riazzerano al cambio di anno e quindi ripartono da 1?

ho provato con macro ma aggiornano sempre la stessa cella
ho provato con conta.se
conta.valori

nulla..non ne vengo fuori...
questo elenco di numeri progressivi, devono risultare in progressivo su una colonna. questi numeri mi serviranno poi come "ID" per un programma di audit.
allego il file di esempio
https://we.tl/1gjbIkXJ2U

grazie
buona giornata
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Sponsor
 

Re: Excel - numerazione progressiva al cambio di anno

Postdi Marius44 » 11/01/18 10:30

Ciao
Prova con questa macro che scrive i numeri progressivi in col. F

Codice: Seleziona tutto
Option Explicit

Sub Nmerazione()
Dim uRiga As Long, i As Long, a As Integer, anno As Integer
uRiga = Cells(Rows.Count, 4).End(xlUp).Row
anno = Cells(2, 4).Value
    For i = 2 To uRiga
        If Cells(i, 4) = "" Then
        ElseIf Cells(i, 4) = anno Then
            a = a + 1
            Cells(i, 6) = a
        ElseIf Cells(i, 4) <> anno Then
            anno = Cells(i, 4).Value
            Cells(i, 6) = 1
            a = 1
        End If
    Next i
End Sub


Fai sapere. Ciao,
Mario
Marius44
Utente Senior
 
Post: 545
Iscritto il: 07/09/15 22:00

Re: Excel - numerazione progressiva al cambio di anno

Postdi xilofono » 11/01/18 10:32

io in genere in questi casi mi affido a una formula tipo questa messa - per esempio - a partire da G2 e trascinata in basso

=SE(D2<>D1;1;G1+1)
Windows 8 - Office 2016 Ita
Avatar utente
xilofono
Utente Junior
 
Post: 65
Iscritto il: 27/11/17 09:52

Re: Excel - numerazione progressiva al cambio di anno

Postdi giostacchio » 11/01/18 12:12

innanzi tutto grazie.

funzionano = NI

nel senso che se per uno strano motivo, io ho pianificato un audit in una certa data, ma poi questo salta e lo devo ripianificare ( quindi magari un anno dopo ) o annullare ( quindi cancello la data ) il numero progressivo nelle due formule che mi avete fornito salta e riparte da uno...

qualche idea ? :oops:
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: Excel - numerazione progressiva al cambio di anno

Postdi giostacchio » 11/01/18 12:14

ecco il file aggiornato con le vostre modifiche

https://we.tl/qBGCyu8ONf

grazie
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: Excel - numerazione progressiva al cambio di anno

Postdi Marius44 » 11/01/18 13:14

Ciao
Non mi è chiara una cosa. Dicevi:
è possibile realizzare un elenco di numeri progressivi che si riazzerano al cambio di anno e quindi ripartono da 1?


A questa domanda la risposta è si.
Cosa c'entra la tua ulteriore domanda?

Attenzione ad un'altra cosa. Con la mia macro non ci devono essere anni mischiati (mi riferisco alle righe 79:81

Ciao,
Mario
Marius44
Utente Senior
 
Post: 545
Iscritto il: 07/09/15 22:00

Re: Excel - numerazione progressiva al cambio di anno

Postdi giostacchio » 11/01/18 14:30

si lo..
avevo allegato il file proprio per far vedere il caso da me descritto successivamente

io ho pianificato un audit in una certa data, ma poi questo salta e lo devo ripianificare ( quindi magari un anno dopo ) o annullare ( quindi cancello la data ) il numero progressivo nelle due formule che mi avete fornito salta e riparte da uno...
qualche idea ? :oops:
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: Excel - numerazione progressiva al cambio di anno

Postdi Marius44 » 11/01/18 18:20

Ciao
Ho l'impressione che non hai le idee abbastanza chiare su quello che vuoi fare (oppure non riesco a capirlo).
Ma come si fa a darti una mano quando, non conoscendo il tuo obiettivo, prima chiedi una cosa e poi un'altra?

Fai un esempio "concreto": ho programmato questo ed ho messo questi numeri progressivi; ad un certo punto non ho proseguito; cancello la data programmata; per i prossimi audit vorrei fare quest'altro.

Ciao
Mario
Marius44
Utente Senior
 
Post: 545
Iscritto il: 07/09/15 22:00

Re: Excel - numerazione progressiva al cambio di anno

Postdi giostacchio » 12/01/18 08:18

ti ringrazio per la pazienza e per l'aiuto..
ho sistemato utilizzando semplicemente =SE(D2<>D1;1;G1+1) e non cancellando nulla
buona giornata
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36


Torna a Applicazioni Office Windows


Topic correlati a "Excel - numerazione progressiva al cambio di anno":


Chi c’è in linea

Visitano il forum: Nessuno e 21 ospiti